aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/FSMC_NAND
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2014-10-18 17:20:29 +0300
committerbarthess <barthess@yandex.ru>2014-10-18 17:20:29 +0300
commit721c48bc978edeeff89e4b1169cb96b1569fdc3a (patch)
treebee730944db7faf53e81394e3c713b2a70026beb /testhal/STM32/STM32F4xx/FSMC_NAND
parentfb205a7d6dee939848797cc25af3b118af025406 (diff)
downloadChibiOS-Contrib-721c48bc978edeeff89e4b1169cb96b1569fdc3a.tar.gz
ChibiOS-Contrib-721c48bc978edeeff89e4b1169cb96b1569fdc3a.tar.bz2
ChibiOS-Contrib-721c48bc978edeeff89e4b1169cb96b1569fdc3a.zip
FSMC. Build fixed after code moving from SVN
Diffstat (limited to 'testhal/STM32/STM32F4xx/FSMC_NAND')
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_NAND/Makefile10
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_NAND/main.c8
2 files changed, 7 insertions, 11 deletions
diff --git a/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile b/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile
index b01a387..3cdf5c4 100644
--- a/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile
@@ -30,7 +30,7 @@ endif
# Enable this if you want link time optimizations (LTO)
ifeq ($(USE_LTO),)
- USE_LTO = yes
+ USE_LTO = no
endif
# If enabled, this option allows to compile the application in THUMB mode.
@@ -80,10 +80,10 @@ endif
PROJECT = ch
# Imported source files and paths
-CHIBIOS = ../../../..
-include $(CHIBIOS)/os/hal/hal.mk
-include $(CHIBIOS)/os/hal/boards/NONSTANDARD_STM32F4_BARTHESS2/board.mk
-include $(CHIBIOS)/os/hal/ports/STM32/STM32F4xx/platform.mk
+CHIBIOS = ../../../../..
+include $(CHIBIOS)/community/os/hal/hal.mk
+include $(CHIBIOS)/community/os/hal/boards/NONSTANDARD_STM32F4_BARTHESS2/board.mk
+include $(CHIBIOS)/community/os/hal/ports/STM32/STM32F4xx/platform.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32f4xx.mk
diff --git a/testhal/STM32/STM32F4xx/FSMC_NAND/main.c b/testhal/STM32/STM32F4xx/FSMC_NAND/main.c
index e695894..c870296 100644
--- a/testhal/STM32/STM32F4xx/FSMC_NAND/main.c
+++ b/testhal/STM32/STM32F4xx/FSMC_NAND/main.c
@@ -1,5 +1,5 @@
/*
- ChibiOS/RT - Copyright (C) 2006-2014 Giovanni Di Sirio
+ ChibiOS/RT - Copyright (C) 2013-2014 Uladzimir Pylinsky aka barthess
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -13,10 +13,6 @@
See the License for the specific language governing permissions and
limitations under the License.
*/
-/*
- Concepts and parts of this file have been contributed by Uladzimir Pylinsky
- aka barthess.
- */
/*
* Hardware notes.
@@ -185,7 +181,7 @@ static const EXTConfig extcfg = {
};
#endif /* STM32_NAND_USE_EXT_INT */
-static uint32_t BackgroundThdCnt = 0;
+static volatile uint32_t BackgroundThdCnt = 0;
#if USE_KILL_BLOCK_TEST
static uint32_t KillCycle = 0;