aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-02-24 00:10:02 +0300
committerbarthess <barthess@yandex.ru>2015-02-24 00:10:02 +0300
commit33f1b2541ef3a15b4ed5875f741d71a19e773217 (patch)
tree7539444eeae1f9fc15986901a8ac37fec041d3e0 /testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
parenta1822c490d9eff67917a8cca2defeff3487b627d (diff)
downloadChibiOS-Contrib-33f1b2541ef3a15b4ed5875f741d71a19e773217.tar.gz
ChibiOS-Contrib-33f1b2541ef3a15b4ed5875f741d71a19e773217.tar.bz2
ChibiOS-Contrib-33f1b2541ef3a15b4ed5875f741d71a19e773217.zip
FSMC_SRAM testhal. Added memtest and membench.
Diffstat (limited to 'testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile')
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
index c70636b..7ae1c80 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
@@ -87,8 +87,7 @@ include $(CHIBIOS)/community/os/hal/ports/STM32/STM32F4xx/platform.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32f4xx.mk
-include $(CHIBIOS)/test/rt/test.mk
-
+include $(CHIBIOS)/os/various/cpp_wrappers/chcpp.mk
# Define linker script file here
LDSCRIPT= $(PORTLD)/STM32F407xG.ld
@@ -97,15 +96,17 @@ LDSCRIPT= $(PORTLD)/STM32F407xG.ld
# setting.
CSRC = $(PORTSRC) \
$(KERNSRC) \
- $(TESTSRC) \
$(HALSRC) \
+ $(OSALSRC) \
$(PLATFORMSRC) \
$(BOARDSRC) \
- main.c
+ main.c \
+ membench.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(CHCPPSRC) \
+ memtest.cpp
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -132,9 +133,9 @@ ASMSRC = $(PORTASM)
INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \
$(HALINC) $(OSALINC) $(PLATFORMINC) $(BOARDINC) \
+ $(CHIBIOS)/os/various/cpp_wrappers \
$(CHIBIOS)/os/various
-
#
# Project, sources and paths
##############################################################################