aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-03-31 00:22:20 +0300
committerbarthess <barthess@yandex.ru>2015-03-31 00:22:20 +0300
commit3aae2d6b821a4ad44c09358ca50baf5dafc57374 (patch)
tree2adea24b41cdf9944cec71010a750fa1621818f3 /testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
parent8c7587372bc8c25a4aab9f46148271a7365bacf6 (diff)
downloadChibiOS-Contrib-3aae2d6b821a4ad44c09358ca50baf5dafc57374.tar.gz
ChibiOS-Contrib-3aae2d6b821a4ad44c09358ca50baf5dafc57374.tar.bz2
ChibiOS-Contrib-3aae2d6b821a4ad44c09358ca50baf5dafc57374.zip
STM32. Updated makefiles.
Diffstat (limited to 'testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile')
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
index 33fc717..ec5d18c 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
@@ -81,25 +81,32 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../..
+# Startup files.
+include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
+# HAL-OSAL files (optional).
include $(CHIBIOS)/community/os/hal/hal.mk
-include $(CHIBIOS)/community/os/hal/boards/NONSTANDARD_STM32F4_BARTHESS2/board.mk
include $(CHIBIOS)/community/os/hal/ports/STM32/STM32F4xx/platform.mk
+include $(CHIBIOS)/community/os/hal/boards/NONSTANDARD_STM32F4_BARTHESS2/board.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
+# RTOS files (optional).
include $(CHIBIOS)/os/rt/rt.mk
-include $(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32f4xx.mk
+include $(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
+# Other files (optional).
include $(CHIBIOS)/os/various/cpp_wrappers/chcpp.mk
# Define linker script file here
-LDSCRIPT= $(PORTLD)/STM32F407xG.ld
+LDSCRIPT= $(STARTUPLD)/STM32F407xG.ld
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(PORTSRC) \
+CSRC = $(STARTUPSRC) \
$(KERNSRC) \
- $(HALSRC) \
+ $(PORTSRC) \
$(OSALSRC) \
+ $(HALSRC) \
$(PLATFORMSRC) \
$(BOARDSRC) \
+ $(TESTSRC) \
main.c \
membench.c \
memcpy_dma.c
@@ -130,10 +137,10 @@ TCSRC =
TCPPSRC =
# List ASM source files here
-ASMSRC = $(PORTASM)
+ASMSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
-INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \
- $(HALINC) $(OSALINC) $(PLATFORMINC) $(BOARDINC) \
+INCDIR = $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
+ $(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
$(CHIBIOS)/os/various/cpp_wrappers \
$(CHIBIOS)/os/various