aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2015-08-20 18:20:46 +0200
committerFabien Poussin <fabien.poussin@gmail.com>2015-08-20 18:20:46 +0200
commit586a8a2b29f1f01074a242b30198d8c638533a00 (patch)
tree667db4c54be523c534b703597b0a4982a78d7d8c /testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
parent48a03708ff6ed34e7b0576e2c2b36587e58779d8 (diff)
downloadChibiOS-Contrib-586a8a2b29f1f01074a242b30198d8c638533a00.tar.gz
ChibiOS-Contrib-586a8a2b29f1f01074a242b30198d8c638533a00.tar.bz2
ChibiOS-Contrib-586a8a2b29f1f01074a242b30198d8c638533a00.zip
Modified makefiles to incorporate changes
Diffstat (limited to 'testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile')
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
index 48376a8..3a70aad 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
@@ -80,13 +80,15 @@ endif
PROJECT = ch
# Imported source files and paths
-CHIBIOS = ../../../../..
+CHIBIOS = ../../../../../ChibiOS-RT
+CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
+CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
# HAL-OSAL files (optional).
-include $(CHIBIOS)/community/os/hal/hal.mk
-include $(CHIBIOS)/community/os/hal/ports/STM32/STM32F4xx/platform.mk
-include $(CHIBIOS)/community/os/hal/boards/NONSTANDARD_STM32F4_BARTHESS2/board.mk
+include $(CHIBIOS_CONTRIB)/os/hal/hal.mk
+include $(CHIBIOS_CONTRIB)/os/hal/ports/STM32/STM32F4xx/platform.mk
+include $(CHIBIOS_CONTRIB)/os/hal/boards/NONSTANDARD_STM32F4_BARTHESS2/board.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
# RTOS files (optional).
include $(CHIBIOS)/os/rt/rt.mk
@@ -114,7 +116,7 @@ CSRC = $(STARTUPSRC) \
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
CPPSRC = $(CHCPPSRC) \
- $(CHIBIOS)/community/os/various/memtest.cpp
+ $(CHIBIOS_CONTRIB)/os/various/memtest.cpp
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -143,7 +145,7 @@ INCDIR = $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
$(CHIBIOS)/os/various/cpp_wrappers \
$(CHIBIOS)/os/various \
- $(CHIBIOS)/community/os/various
+ $(CHIBIOS_CONTRIB)/os/various
#
# Project, sources and paths