aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/onewire/Makefile
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2016-10-18 12:02:55 +0300
committerbarthess <barthess@yandex.ru>2016-10-18 12:02:55 +0300
commit555f301da2f276cc353a8e2d0a283a488bd8eeff (patch)
tree2ae51b49dec5bf94ef79ea97a66a263a2aef7b88 /testhal/STM32/STM32F4xx/onewire/Makefile
parentbd47894d622acbc18bf99b0b46bf7b0ed7330634 (diff)
downloadChibiOS-Contrib-555f301da2f276cc353a8e2d0a283a488bd8eeff.tar.gz
ChibiOS-Contrib-555f301da2f276cc353a8e2d0a283a488bd8eeff.tar.bz2
ChibiOS-Contrib-555f301da2f276cc353a8e2d0a283a488bd8eeff.zip
1-Wire. Duplicated code from testhal apllications moved to separate directory.
Diffstat (limited to 'testhal/STM32/STM32F4xx/onewire/Makefile')
-rw-r--r--testhal/STM32/STM32F4xx/onewire/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/testhal/STM32/STM32F4xx/onewire/Makefile b/testhal/STM32/STM32F4xx/onewire/Makefile
index 02ab018..5adcca3 100644
--- a/testhal/STM32/STM32F4xx/onewire/Makefile
+++ b/testhal/STM32/STM32F4xx/onewire/Makefile
@@ -88,6 +88,7 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
+TESTHAL = $(CHIBIOS_CONTRIB)/testhal/hw_abstracted/onewire
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
# HAL-OSAL files (optional).
@@ -113,7 +114,7 @@ CSRC = $(STARTUPSRC) \
$(BOARDSRC) \
$(TESTSRC) \
main.c \
- onewire_test.c
+ $(TESTHAL)/testhal_onewire.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
@@ -146,7 +147,8 @@ ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
INCDIR = $(CHIBIOS)/os/license \
$(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various
+ $(CHIBIOS)/os/various \
+ $(TESTHAL)
#
# Project, sources and paths