aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32
diff options
context:
space:
mode:
authorUladzimir Pylinski <barthess@yandex.ru>2016-07-08 00:26:19 +0300
committerGitHub <noreply@github.com>2016-07-08 00:26:19 +0300
commit0375554e956f96453e9381bf01bbe092ae218359 (patch)
tree6f284c2788d237553abfea2e5a503f977871903d /testhal/STM32
parentba752b1b7e14402fabce7a5d11a24dadfbc6e0ba (diff)
parent60ce974437bd0cd4f59a7bf2617a81644253aacf (diff)
downloadChibiOS-Contrib-0375554e956f96453e9381bf01bbe092ae218359.tar.gz
ChibiOS-Contrib-0375554e956f96453e9381bf01bbe092ae218359.tar.bz2
ChibiOS-Contrib-0375554e956f96453e9381bf01bbe092ae218359.zip
Merge pull request #87 from sdalu/qei
qeiAdjustI
Diffstat (limited to 'testhal/STM32')
-rw-r--r--testhal/STM32/STM32F0xx/qei/Makefile2
-rw-r--r--testhal/STM32/STM32F0xx/qei/halconf_community.h18
2 files changed, 19 insertions, 1 deletions
diff --git a/testhal/STM32/STM32F0xx/qei/Makefile b/testhal/STM32/STM32F0xx/qei/Makefile
index 6dbcf91..6f2e54c 100644
--- a/testhal/STM32/STM32F0xx/qei/Makefile
+++ b/testhal/STM32/STM32F0xx/qei/Makefile
@@ -86,7 +86,7 @@ endif
PROJECT = ch
# Imported source files and paths
-CHIBIOS = ../../../../../ChibiOS-RT
+CHIBIOS = ../../../../../ChibiOS
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/mk/startup_stm32f0xx.mk
diff --git a/testhal/STM32/STM32F0xx/qei/halconf_community.h b/testhal/STM32/STM32F0xx/qei/halconf_community.h
index 9c28ead..95f1ee6 100644
--- a/testhal/STM32/STM32F0xx/qei/halconf_community.h
+++ b/testhal/STM32/STM32F0xx/qei/halconf_community.h
@@ -100,6 +100,24 @@
*/
#define ONEWIRE_USE_SEARCH_ROM FALSE
+/*===========================================================================*/
+/* QEI driver related settings. */
+/*===========================================================================*/
+
+/**
+ * @brief Enables discard of overlow
+ */
+#if !defined(QEI_USE_OVERFLOW_DISCARD) || defined(__DOXYGEN__)
+#define QEI_USE_OVERFLOW_DISCARD FALSE
+#endif
+
+/**
+ * @brief Enables min max of overlow
+ */
+#if !defined(QEI_USE_OVERFLOW_MINMAX) || defined(__DOXYGEN__)
+#define QEI_USE_OVERFLOW_MINMAX FALSE
+#endif
+
#endif /* HALCONF_COMMUNITY_H */
/** @} */