aboutsummaryrefslogtreecommitdiffstats
path: root/testhal
diff options
context:
space:
mode:
authorStephane D'Alu <sdalu@sdalu.com>2016-07-07 21:25:51 +0200
committerStephane D'Alu <sdalu@sdalu.com>2016-07-07 21:25:51 +0200
commitf75abd1037a5c2eb119533eb2f4c7c16d874abf2 (patch)
tree0c2af621c9380d1cea37df8cdddd55eccd3b6088 /testhal
parent9c88423d66e9b4eafecc658058f25f79e08ff120 (diff)
downloadChibiOS-Contrib-f75abd1037a5c2eb119533eb2f4c7c16d874abf2.tar.gz
ChibiOS-Contrib-f75abd1037a5c2eb119533eb2f4c7c16d874abf2.tar.bz2
ChibiOS-Contrib-f75abd1037a5c2eb119533eb2f4c7c16d874abf2.zip
added qeiAdjustI. added new field and checking in STM32
Diffstat (limited to 'testhal')
-rw-r--r--testhal/STM32/STM32F0xx/qei/Makefile2
-rw-r--r--testhal/STM32/STM32F0xx/qei/halconf_community.h18
2 files changed, 19 insertions, 1 deletions
diff --git a/testhal/STM32/STM32F0xx/qei/Makefile b/testhal/STM32/STM32F0xx/qei/Makefile
index 6dbcf91..6f2e54c 100644
--- a/testhal/STM32/STM32F0xx/qei/Makefile
+++ b/testhal/STM32/STM32F0xx/qei/Makefile
@@ -86,7 +86,7 @@ endif
PROJECT = ch
# Imported source files and paths
-CHIBIOS = ../../../../../ChibiOS-RT
+CHIBIOS = ../../../../../ChibiOS
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/mk/startup_stm32f0xx.mk
diff --git a/testhal/STM32/STM32F0xx/qei/halconf_community.h b/testhal/STM32/STM32F0xx/qei/halconf_community.h
index 9c28ead..95f1ee6 100644
--- a/testhal/STM32/STM32F0xx/qei/halconf_community.h
+++ b/testhal/STM32/STM32F0xx/qei/halconf_community.h
@@ -100,6 +100,24 @@
*/
#define ONEWIRE_USE_SEARCH_ROM FALSE
+/*===========================================================================*/
+/* QEI driver related settings. */
+/*===========================================================================*/
+
+/**
+ * @brief Enables discard of overlow
+ */
+#if !defined(QEI_USE_OVERFLOW_DISCARD) || defined(__DOXYGEN__)
+#define QEI_USE_OVERFLOW_DISCARD FALSE
+#endif
+
+/**
+ * @brief Enables min max of overlow
+ */
+#if !defined(QEI_USE_OVERFLOW_MINMAX) || defined(__DOXYGEN__)
+#define QEI_USE_OVERFLOW_MINMAX FALSE
+#endif
+
#endif /* HALCONF_COMMUNITY_H */
/** @} */