aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk3
-rw-r--r--os/hal/ports/KINETIS/LLD/hal_pal_lld.h5
2 files changed, 2 insertions, 6 deletions
diff --git a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk
index 693ae67..450ec41 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk
+++ b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk
@@ -5,6 +5,7 @@ STARTUPSRC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt1.c \
STARTUPASM = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt0_v7m.S
STARTUPINC = $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/devices/NRF52832 \
- $(CHIBIOS)/os/common/ext/CMSIS/include
+ $(CHIBIOS)/os/common/ext/CMSIS/include \
+ $(CHIBIOS)/os/common/ext/ARM/CMSIS/Core/Include
STARTUPLD = $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/compilers/GCC/ld
diff --git a/os/hal/ports/KINETIS/LLD/hal_pal_lld.h b/os/hal/ports/KINETIS/LLD/hal_pal_lld.h
index 6129f69..833d95e 100644
--- a/os/hal/ports/KINETIS/LLD/hal_pal_lld.h
+++ b/os/hal/ports/KINETIS/LLD/hal_pal_lld.h
@@ -83,11 +83,6 @@ typedef uint32_t ioline_t;
typedef GPIO_TypeDef *ioportid_t;
/**
- * @brief Type of an pad identifier.
- */
-typedef uint32_t iopadid_t;
-
-/**
* @brief Port Configuration.
* @details This structure stores the configuration parameters of all pads
* belonging to a port.