aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.c2
-rw-r--r--os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.h2
-rw-r--r--testhal/TIVA/multi/PAL/Makefile8
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/chconf.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/chconf.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/halconf.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/halconf.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/mcuconf.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/mcuconf.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/portab.c (renamed from testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/portab.c)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/portab.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/portab.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/chconf.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/chconf.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/halconf.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/halconf.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/mcuconf.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/mcuconf.h)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/portab.c (renamed from testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/portab.c)0
-rw-r--r--testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/portab.h (renamed from testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/portab.h)0
-rw-r--r--testhal/TIVA/multi/PAL/make/tm4c123g_launchpad (renamed from testhal/TIVA/multi/PAL/Makefile-tm4c123g_launchpad)6
-rw-r--r--testhal/TIVA/multi/PAL/make/tm4c1294_launchpad (renamed from testhal/TIVA/multi/PAL/Makefile-tm4c1294_launchpad)6
15 files changed, 12 insertions, 12 deletions
diff --git a/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.c b/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.c
index 126959f..2255110 100644
--- a/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.c
+++ b/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.c
@@ -258,7 +258,7 @@ void spi_lld_start(SPIDriver *spip)
nvicEnableVector(TIVA_SSI1_NUMBER, TIVA_SPI_SSI1_IRQ_PRIORITY);
}
#endif
-#if TIVASPI_USE_SSI2
+#if TIVA_SPI_USE_SSI2
if (&SPID2 == spip) {
bool b;
b = udmaChannelAllocate(spip->dmarxnr);
diff --git a/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.h b/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.h
index 4dcf6db..c93c189 100644
--- a/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.h
+++ b/os/hal/ports/TIVA/LLD/SSI/hal_spi_lld.h
@@ -156,7 +156,7 @@
#error "Invalid IRQ priority assigned to SSI2"
#endif
-#if TM4C123x_SPI_USE_SSI3 && \
+#if TIVA_SPI_USE_SSI3 && \
!OSAL_IRQ_IS_VALID_PRIORITY(TIVA_SPI_SSI3_IRQ_PRIORITY)
#error "Invalid IRQ priority assigned to SSI3"
#endif
diff --git a/testhal/TIVA/multi/PAL/Makefile b/testhal/TIVA/multi/PAL/Makefile
index 9efbf47..a9ef661 100644
--- a/testhal/TIVA/multi/PAL/Makefile
+++ b/testhal/TIVA/multi/PAL/Makefile
@@ -5,19 +5,19 @@
all:
@echo
@echo === Building for TM4C123G LaunchPad ================================
- @make --no-print-directory -f Makefile-tm4c123g_launchpad all
+ @make --no-print-directory -f ./make/tm4c123g_launchpad all
@echo ====================================================================
@echo
@echo === Building for TM4C1294 Connected LaunchPad ======================
- @make --no-print-directory -f Makefile-tm4c1294_launchpad all
+ @make --no-print-directory -f ./make/tm4c1294_launchpad all
@echo ====================================================================
@echo
clean:
@echo
- -@make --no-print-directory -f Makefile-tm4c123g_launchpad clean
+ -@make --no-print-directory -f ./make/tm4c123g_launchpad clean
@echo
- -@make --no-print-directory -f Makefile-tm4c1294_launchpad clean
+ -@make --no-print-directory -f ./make/tm4c1294_launchpad clean
@echo
#
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/chconf.h b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/chconf.h
index e42b74e..e42b74e 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/chconf.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/chconf.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/halconf.h b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/halconf.h
index 97f1ec3..97f1ec3 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/halconf.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/halconf.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/mcuconf.h b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/mcuconf.h
index f59dcb7..f59dcb7 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/mcuconf.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/mcuconf.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/portab.c b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/portab.c
index c153bd7..c153bd7 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/portab.c
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/portab.c
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/portab.h b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/portab.h
index 8e62cee..8e62cee 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c123g_launchpad/portab.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c123g_launchpad/portab.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/chconf.h b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/chconf.h
index 3209f1d..3209f1d 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/chconf.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/chconf.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/halconf.h b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/halconf.h
index 97f1ec3..97f1ec3 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/halconf.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/halconf.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/mcuconf.h b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/mcuconf.h
index 578d4ab..578d4ab 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/mcuconf.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/mcuconf.h
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/portab.c b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/portab.c
index c153bd7..c153bd7 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/portab.c
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/portab.c
diff --git a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/portab.h b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/portab.h
index 79ae8ec..79ae8ec 100644
--- a/testhal/TIVA/multi/PAL/cfg-tm4c1294_launchpad/portab.h
+++ b/testhal/TIVA/multi/PAL/cfg/tm4c1294_launchpad/portab.h
diff --git a/testhal/TIVA/multi/PAL/Makefile-tm4c123g_launchpad b/testhal/TIVA/multi/PAL/make/tm4c123g_launchpad
index 9df1d01..5aba90a 100644
--- a/testhal/TIVA/multi/PAL/Makefile-tm4c123g_launchpad
+++ b/testhal/TIVA/multi/PAL/make/tm4c123g_launchpad
@@ -88,9 +88,9 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
-CONFDIR := ./cfg-tm4c123g_launchpad
-BUILDDIR := ./build-tm4c123g_launchpad
-DEPDIR := ./.dep-tm4c123g_launchpad
+CONFDIR := ./cfg/tm4c123g_launchpad
+BUILDDIR := ./build/tm4c123g_launchpad
+DEPDIR := ./.dep/tm4c123g_launchpad
# Licensing files.
include $(CHIBIOS)/os/license/license.mk
diff --git a/testhal/TIVA/multi/PAL/Makefile-tm4c1294_launchpad b/testhal/TIVA/multi/PAL/make/tm4c1294_launchpad
index caec0ac..82523ed 100644
--- a/testhal/TIVA/multi/PAL/Makefile-tm4c1294_launchpad
+++ b/testhal/TIVA/multi/PAL/make/tm4c1294_launchpad
@@ -88,9 +88,9 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
-CONFDIR := ./cfg-tm4c1294_launchpad
-BUILDDIR := ./build-tm4c1294_launchpad
-DEPDIR := ./.dep-tm4c1294_launchpad
+CONFDIR := ./cfg/tm4c1294_launchpad
+BUILDDIR := ./build/tm4c1294_launchpad
+DEPDIR := ./.dep/tm4c1294_launchpad
# Licensing files.
include $(CHIBIOS)/os/license/license.mk