aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/startup/ARMCMx
diff options
context:
space:
mode:
Diffstat (limited to 'os/common/startup/ARMCMx')
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/NRF52832.ld84
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xC3.ld2
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xD5.ld2
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xE6.ld2
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xH6.ld2
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xKC.ld2
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xNC.ld2
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk10
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c123x.mk18
-rw-r--r--os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c129x.mk18
-rw-r--r--os/common/startup/ARMCMx/devices/NRF52832/cmparams.h82
-rw-r--r--os/common/startup/ARMCMx/devices/TM4C123x/cmparams.h121
-rw-r--r--os/common/startup/ARMCMx/devices/TM4C129x/cmparams.h92
13 files changed, 328 insertions, 109 deletions
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/NRF52832.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/NRF52832.ld
new file mode 100644
index 0000000..402995a
--- /dev/null
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/NRF52832.ld
@@ -0,0 +1,84 @@
+/*
+ Copyright (C) 2016 Stephane D'Alu
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/*
+ * NRF52832 memory setup.
+ */
+MEMORY
+{
+ flash0 : org = 0x00000000, len = 512k
+ flash1 : org = 0x00000000, len = 0
+ flash2 : org = 0x00000000, len = 0
+ flash3 : org = 0x00000000, len = 0
+ flash4 : org = 0x00000000, len = 0
+ flash5 : org = 0x00000000, len = 0
+ flash6 : org = 0x00000000, len = 0
+ flash7 : org = 0x00000000, len = 0
+ ram0 : org = 0x20000000, len = 64k
+ ram1 : org = 0x00000000, len = 0
+ ram2 : org = 0x00000000, len = 0
+ ram3 : org = 0x00000000, len = 0
+ ram4 : org = 0x00000000, len = 0
+ ram5 : org = 0x00000000, len = 0
+ ram6 : org = 0x00000000, len = 0
+ ram7 : org = 0x00000000, len = 0
+}
+
+/* For each data/text section two region are defined, a virtual region
+ and a load region (_LMA suffix).*/
+
+/* Flash region to be used for exception vectors.*/
+REGION_ALIAS("VECTORS_FLASH", flash0);
+REGION_ALIAS("VECTORS_FLASH_LMA", flash0);
+
+/* Flash region to be used for constructors and destructors.*/
+REGION_ALIAS("XTORS_FLASH", flash0);
+REGION_ALIAS("XTORS_FLASH_LMA", flash0);
+
+/* Flash region to be used for code text.*/
+REGION_ALIAS("TEXT_FLASH", flash0);
+REGION_ALIAS("TEXT_FLASH_LMA", flash0);
+
+/* Flash region to be used for read only data.*/
+REGION_ALIAS("RODATA_FLASH", flash0);
+REGION_ALIAS("RODATA_FLASH_LMA", flash0);
+
+/* Flash region to be used for various.*/
+REGION_ALIAS("VARIOUS_FLASH", flash0);
+REGION_ALIAS("VARIOUS_FLASH_LMA", flash0);
+
+/* Flash region to be used for RAM(n) initialization data.*/
+REGION_ALIAS("RAM_INIT_FLASH_LMA", flash0);
+
+/* RAM region to be used for Main stack. This stack accommodates the processing
+ of all exceptions and interrupts*/
+REGION_ALIAS("MAIN_STACK_RAM", ram0);
+
+/* RAM region to be used for the process stack. This is the stack used by
+ the main() function.*/
+REGION_ALIAS("PROCESS_STACK_RAM", ram0);
+
+/* RAM region to be used for data segment.*/
+REGION_ALIAS("DATA_RAM", ram0);
+REGION_ALIAS("DATA_RAM_LMA", flash0);
+
+/* RAM region to be used for BSS segment.*/
+REGION_ALIAS("BSS_RAM", ram0);
+
+/* RAM region to be used for HEAP segment.*/
+REGION_ALIAS("HEAP_RAM", ram0);
+
+INCLUDE rules.ld
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xC3.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xC3.ld
index da05e8a..9eeaf02 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xC3.ld
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xC3.ld
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xD5.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xD5.ld
index 1a1c89e..67d33ca 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xD5.ld
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xD5.ld
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xE6.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xE6.ld
index 254cb3a..83a3edd 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xE6.ld
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xE6.ld
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xH6.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xH6.ld
index f73f9ec..1affc86 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xH6.ld
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C123xH6.ld
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xKC.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xKC.ld
index 0463ba0..aef12ea 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xKC.ld
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xKC.ld
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xNC.ld b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xNC.ld
index f1846ca..5e7bdb9 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xNC.ld
+++ b/os/common/startup/ARMCMx/compilers/GCC/ld/TM4C129xNC.ld
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk
new file mode 100644
index 0000000..693ae67
--- /dev/null
+++ b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf52.mk
@@ -0,0 +1,10 @@
+# List of the ChibiOS generic NRF51 startup and CMSIS files.
+STARTUPSRC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt1.c \
+ $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/vectors.c
+
+STARTUPASM = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt0_v7m.S
+
+STARTUPINC = $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/devices/NRF52832 \
+ $(CHIBIOS)/os/common/ext/CMSIS/include
+
+STARTUPLD = $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/compilers/GCC/ld
diff --git a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c123x.mk b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c123x.mk
index 8457328..835faca 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c123x.mk
+++ b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c123x.mk
@@ -1,12 +1,18 @@
# List of the ChibiOS generic TM4C123x startup and CMSIS files.
-STARTUPSRC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt1.c \
- $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/vectors.c
+STARTUPSRC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt1.c
-STARTUPASM = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt0_v7m.S
+STARTUPASM = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt0_v7m.S \
+ $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/vectors.S
-STARTUPINC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC \
+STARTUPINC = $(CHIBIOS)/os/common/portability/GCC \
+ $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC \
$(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/devices/TM4C123x \
- $(CHIBIOS)/os/common/ext/CMSIS/include \
- $(CHIBIOS)/os/common/ext/ARM/CMSIS/Core/Include
+ $(CHIBIOS)/os/common/ext/ARM/CMSIS/Core/Include \
+ $(CHIBIOS_CONTRIB)/os/common/ext/TivaWare
STARTUPLD = $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/compilers/GCC/ld
+
+# Shared variables
+ALLXASMSRC += $(STARTUPASM)
+ALLCSRC += $(STARTUPSRC)
+ALLINC += $(STARTUPINC)
diff --git a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c129x.mk b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c129x.mk
index e488537..ac4f76e 100644
--- a/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c129x.mk
+++ b/os/common/startup/ARMCMx/compilers/GCC/mk/startup_tm4c129x.mk
@@ -1,12 +1,18 @@
# List of the ChibiOS generic TM4C129x startup and CMSIS files.
-STARTUPSRC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt1.c \
- $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/vectors.c
+STARTUPSRC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt1.c
-STARTUPASM = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt0_v7m.S
+STARTUPASM = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/crt0_v7m.S \
+ $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/vectors.S
-STARTUPINC = $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC \
+STARTUPINC = $(CHIBIOS)/os/common/portability/GCC \
+ $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC \
$(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/devices/TM4C129x \
- $(CHIBIOS)/os/common/ext/CMSIS/include \
- $(CHIBIOS)/os/common/ext/ARM/CMSIS/Core/Include
+ $(CHIBIOS)/os/common/ext/ARM/CMSIS/Core/Include \
+ $(CHIBIOS_CONTRIB)/os/common/ext/TivaWare
STARTUPLD = $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/compilers/GCC/ld
+
+# Shared variables
+ALLXASMSRC += $(STARTUPASM)
+ALLCSRC += $(STARTUPSRC)
+ALLINC += $(STARTUPINC)
diff --git a/os/common/startup/ARMCMx/devices/NRF52832/cmparams.h b/os/common/startup/ARMCMx/devices/NRF52832/cmparams.h
new file mode 100644
index 0000000..b349291
--- /dev/null
+++ b/os/common/startup/ARMCMx/devices/NRF52832/cmparams.h
@@ -0,0 +1,82 @@
+/*
+ Copyright (C) 2016 Stephane D'Alu
+
+ This file is part of ChibiOS.
+
+ ChibiOS is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file NRF51822/cmparams.h
+ * @brief ARM Cortex-M4 parameters for the Nordic Semi NRF52832 family.
+ *
+ * @defgroup ARMCMx_NRF52x Nordic semiconductor NRF52x.
+ * @ingroup ARMCMx_SPECIFIC
+ * @details This file contains the Cortex-M4 specific parameters for the
+ * NRF52x platform.
+ * @{
+ */
+
+#ifndef _CMPARAMS_H_
+#define _CMPARAMS_H_
+
+/**
+ * @brief Cortex core model.
+ */
+#define CORTEX_MODEL 4
+
+/**
+ * @brief Memory Protection unit presence.
+ */
+#define CORTEX_HAS_MPU 1
+
+/**
+ * @brief Floating Point unit presence.
+ */
+#define CORTEX_HAS_FPU 1
+
+/**
+ * @brief Number of bits in priority masks.
+ */
+#define CORTEX_PRIORITY_BITS 3
+
+/**
+ * @brief Number of interrupt vectors.
+ * @note This number does not include the 16 system vectors and must be
+ * rounded to a multiple of 8.
+ */
+#define CORTEX_NUM_VECTORS 40
+
+/* The following code is not processed when the file is included from an
+ asm module.*/
+#if !defined(_FROM_ASM_)
+
+/* Including the device CMSIS header. Note, we are not using the definitions
+ from this header because we need this file to be usable also from
+ assembler source files. We verify that the info matches instead.*/
+#include "nrf52.h"
+
+#if CORTEX_MODEL != __CORTEX_M
+#error "CMSIS __CORTEX_M mismatch"
+#endif
+
+#if CORTEX_PRIORITY_BITS != __NVIC_PRIO_BITS
+#error "CMSIS __NVIC_PRIO_BITS mismatch"
+#endif
+
+#endif /* !defined(_FROM_ASM_) */
+
+#endif /* _CMPARAMS_H_ */
+
+/** @} */
diff --git a/os/common/startup/ARMCMx/devices/TM4C123x/cmparams.h b/os/common/startup/ARMCMx/devices/TM4C123x/cmparams.h
index 933e111..7c40591 100644
--- a/os/common/startup/ARMCMx/devices/TM4C123x/cmparams.h
+++ b/os/common/startup/ARMCMx/devices/TM4C123x/cmparams.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -17,11 +17,26 @@
/**
* @file TM4C123x/cmparams.h
* @brief ARM Cortex-M4 parameters for the TM4C123x.
+ *
+ * @defgroup ARMCMx_TM4C123x TM4C123x Specific Parameters
+ * @ingroup ARMCMx_SPECIFIC
+ * @details This file contains the Cortex-M4 specific parameters for the
+ * TM4C123x platform.
* @{
*/
-#ifndef _CMPARAMS_H_
-#define _CMPARAMS_H_
+#ifndef CMPARAMS_H
+#define CMPARAMS_H
+
+/* Defines required for correct CMSIS header functioning */
+#define __MPU_PRESENT 1 /**< MPU present */
+#define __NVIC_PRIO_BITS 3 /**< Bits used for Priority Levels */
+#define __Vendor_SysTickConfig 1 /**< Use different SysTick Config */
+#define __FPU_PRESENT 1 /**< FPU present */
+
+/* The following two defines are needed by ChibiOS */
+#define SVCall_IRQn -5
+#define PendSV_IRQn -3
/**
* @brief Cortex core model.
@@ -29,11 +44,6 @@
#define CORTEX_MODEL 4
/**
- * @brief Memory Protection unit presence.
- */
-#define CORTEX_HAS_MPU 1
-
-/**
* @brief Floating Point unit presence.
*/
#define CORTEX_HAS_FPU 1
@@ -57,56 +67,61 @@
/* If the device type is not externally defined, for example from the Makefile,
then a file named board.h is included. This file must contain a device
definition compatible with the include file.*/
-#if !defined(TM4C1230C3PM) && !defined(TM4C1230D5PM) && \
- !defined(TM4C1230E6PM) && !defined(TM4C1230H6PM) && \
- !defined(TM4C1231C3PM) && !defined(TM4C1231D5PM) && \
- !defined(TM4C1231D5PZ) && !defined(TM4C1231E6PM) && \
- !defined(TM4C1231E6PZ) && !defined(TM4C1231H6PGE) && \
- !defined(TM4C1231H6PM) && !defined(TM4C1231H6PZ) && \
- !defined(TM4C1232C3PM) && !defined(TM4C1232D5PM) && \
- !defined(TM4C1232E6PM) && !defined(TM4C1232H6PM) && \
- !defined(TM4C1233C3PM) && !defined(TM4C1233D5PM) && \
- !defined(TM4C1233D5PZ) && !defined(TM4C1233E6PM) && \
- !defined(TM4C1233E6PZ) && !defined(TM4C1233H6PGE) && \
- !defined(TM4C1233H6PM) && !defined(TM4C1233H6PZ) && \
- !defined(TM4C1236D5PM) && !defined(TM4C1236E6PM) && \
- !defined(TM4C1236H6PM) && !defined(TM4C1237D5PM) && \
- !defined(TM4C1237D5PZ) && !defined(TM4C1237E6PM) && \
- !defined(TM4C1237E6PZ) && !defined(TM4C1237H6PGE) && \
- !defined(TM4C1237H6PM) && !defined(TM4C1237H6PZ) && \
- !defined(TM4C123AE6PM) && !defined(TM4C123AH6PM) && \
- !defined(TM4C123BE6PM) && !defined(TM4C123BE6PZ) && \
- !defined(TM4C123BH6PGE) && !defined(TM4C123BH6PM) && \
- !defined(TM4C123BH6PZ) && !defined(TM4C123BH6ZRB) && \
- !defined(TM4C123FE6PM) && !defined(TM4C123FH6PM) && \
- !defined(TM4C123GE6PM) && !defined(TM4C123GE6PZ) && \
- !defined(TM4C123GH6PGE) && !defined(TM4C123GH6PM) && \
- !defined(TM4C123GH6PZ) && !defined(TM4C123GH6ZRB) && \
- !defined(TM4C123GH5ZXR)
+#if !defined (PART_TM4C1230C3PM) && !defined (PART_TM4C1230D5PM) && \
+ !defined (PART_TM4C1230E6PM) && !defined (PART_TM4C1230H6PM) && \
+ !defined (PART_TM4C1231C3PM) && !defined (PART_TM4C1231D5PM) && \
+ !defined (PART_TM4C1231D5PZ) && !defined (PART_TM4C1231E6PM) && \
+ !defined (PART_TM4C1231E6PZ) && !defined (PART_TM4C1231H6PGE) && \
+ !defined (PART_TM4C1231H6PM) && !defined (PART_TM4C1231H6PZ) && \
+ !defined (PART_TM4C1232C3PM) && !defined (PART_TM4C1232D5PM) && \
+ !defined (PART_TM4C1232E6PM) && !defined (PART_TM4C1232H6PM) && \
+ !defined (PART_TM4C1233C3PM) && !defined (PART_TM4C1233D5PM) && \
+ !defined (PART_TM4C1233D5PZ) && !defined (PART_TM4C1233E6PM) && \
+ !defined (PART_TM4C1233E6PZ) && !defined (PART_TM4C1233H6PGE) && \
+ !defined (PART_TM4C1233H6PM) && !defined (PART_TM4C1233H6PZ) && \
+ !defined (PART_TM4C1236D5PM) && !defined (PART_TM4C1236E6PM) && \
+ !defined (PART_TM4C1236H6PM) && !defined (PART_TM4C1237D5PM) && \
+ !defined (PART_TM4C1237D5PZ) && !defined (PART_TM4C1237E6PM) && \
+ !defined (PART_TM4C1237E6PZ) && !defined (PART_TM4C1237H6PGE) && \
+ !defined (PART_TM4C1237H6PM) && !defined (PART_TM4C1237H6PZ) && \
+ !defined (PART_TM4C123AE6PM) && !defined (PART_TM4C123AH6PM) && \
+ !defined (PART_TM4C123BE6PM) && !defined (PART_TM4C123BE6PZ) && \
+ !defined (PART_TM4C123BH6PGE) && !defined (PART_TM4C123BH6PM) && \
+ !defined (PART_TM4C123BH6PZ) && !defined (PART_TM4C123BH6ZRB) && \
+ !defined (PART_TM4C123FE6PM) && !defined (PART_TM4C123FH6PM) && \
+ !defined (PART_TM4C123GE6PM) && !defined (PART_TM4C123GE6PZ) && \
+ !defined (PART_TM4C123GH6PGE) && !defined (PART_TM4C123GH6PM) && \
+ !defined (PART_TM4C123GH6PZ) && !defined (PART_TM4C123GH6ZRB) && \
+ !defined (PART_TM4C123GH5ZXR)
#include "board.h"
#endif
-/* Including the device CMSIS header. Note, we are not using the definitions
- from this header because we need this file to be usable also from
- assembler source files. We verify that the info matches instead.*/
-#include "tm4c123x.h"
-
-#if !CORTEX_HAS_MPU != !__MPU_PRESENT
-#error "CMSIS __MPU_PRESENT mismatch"
-#endif
-
-#if !CORTEX_HAS_FPU != !__FPU_PRESENT
-#error "CMSIS __FPU_PRESENT mismatch"
-#endif
-
-#if CORTEX_PRIORITY_BITS != __NVIC_PRIO_BITS
-#error "CMSIS __NVIC_PRIO_BITS mismatch"
+typedef int IRQn_Type;
+
+#include "core_cm4.h"
+
+/* Including the TivaWare peripheral headers.*/
+#include "inc/hw_ints.h"
+#include "inc/hw_memmap.h"
+#include "inc/hw_types.h"
+#include "inc/hw_timer.h"
+#include "inc/hw_sysctl.h"
+#include "inc/hw_gpio.h"
+#include "inc/hw_uart.h"
+#include "inc/hw_timer.h"
+#include "inc/hw_i2c.h"
+#include "inc/hw_watchdog.h"
+#include "inc/hw_ssi.h"
+#include "inc/hw_udma.h"
+#include "inc/hw_pwm.h"
+#include "inc/hw_adc.h"
+
+#if CORTEX_NUM_VECTORS != ((((NUM_INTERRUPTS - 16) + 7) / 8) * 8)
+#error "TivaWare NUM_INTERRUPTS mismatch"
#endif
#endif /* !defined(_FROM_ASM_) */
-#endif /* _CMPARAMS_H_ */
+#endif /* CMPARAMS_H */
-/**
- * @}
- */
+/** @} */
diff --git a/os/common/startup/ARMCMx/devices/TM4C129x/cmparams.h b/os/common/startup/ARMCMx/devices/TM4C129x/cmparams.h
index 1d2661d..7bf68a0 100644
--- a/os/common/startup/ARMCMx/devices/TM4C129x/cmparams.h
+++ b/os/common/startup/ARMCMx/devices/TM4C129x/cmparams.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -17,11 +17,26 @@
/**
* @file TM4C129x/cmparams.h
* @brief ARM Cortex-M4 parameters for the TM4C129x.
+ *
+ * @defgroup ARMCMx_TM4C129x TM4C129x Specific Parameters
+ * @ingroup ARMCMx_SPECIFIC
+ * @details This file contains the Cortex-M4 specific parameters for the
+ * TM4C129x platform.
* @{
*/
-#ifndef _CMPARAMS_H_
-#define _CMPARAMS_H_
+#ifndef CMPARAMS_H
+#define CMPARAMS_H
+
+/* Defines required for correct CMSIS header functioning */
+#define __MPU_PRESENT 1 /**< MPU present */
+#define __NVIC_PRIO_BITS 3 /**< Bits used for Priority Levels */
+#define __Vendor_SysTickConfig 1 /**< Use different SysTick Config */
+#define __FPU_PRESENT 1 /**< FPU present */
+
+/* The following two defines are needed by ChibiOS */
+#define SVCall_IRQn -5
+#define PendSV_IRQn -3
/**
* @brief Cortex core model.
@@ -29,11 +44,6 @@
#define CORTEX_MODEL 4
/**
- * @brief Memory Protection unit presence.
- */
-#define CORTEX_HAS_MPU 1
-
-/**
* @brief Floating Point unit presence.
*/
#define CORTEX_HAS_FPU 1
@@ -48,7 +58,7 @@
* @note This number does not include the 16 system vectors and must be
* rounded to a multiple of 8.
*/
-#define CORTEX_NUM_VECTORS 112
+#define CORTEX_NUM_VECTORS 120
/* The following code is not processed when the file is included from an
asm module.*/
@@ -57,40 +67,46 @@
/* If the device type is not externally defined, for example from the Makefile,
then a file named board.h is included. This file must contain a device
definition compatible with the include file.*/
-#if !defined(TM4C1290NCPDT) && !defined(TM4C1290NCZAD) \
- && !defined(TM4C1292NCPDT) && !defined(TM4C1292NCZAD) \
- && !defined(TM4C1294KCPDT) && !defined(TM4C1294NCPDT) \
- && !defined(TM4C1294NCZAD) && !defined(TM4C1297NCZAD) \
- && !defined(TM4C1299KCZAD) && !defined(TM4C1299NCZAD) \
- && !defined(TM4C129CNCPDT) && !defined(TM4C129CNCZAD) \
- && !defined(TM4C129DNCPDT) && !defined(TM4C129DNCZAD) \
- && !defined(TM4C129EKCPDT) && !defined(TM4C129ENCPDT) \
- && !defined(TM4C129ENCZAD) && !defined(TM4C129LNCZAD) \
- && !defined(TM4C129XKCZAD) && !defined(TM4C129XNCZAD)
+#if !defined (PART_TM4C1290NCPDT) && !defined (PART_TM4C1290NCZAD) && \
+ !defined (PART_TM4C1292NCPDT) && !defined (PART_TM4C1292NCZAD) && \
+ !defined (PART_TM4C1294KCPDT) && !defined (PART_TM4C1294NCPDT) && \
+ !defined (PART_TM4C1294NCZAD) && !defined (PART_TM4C1297NCZAD) && \
+ !defined (PART_TM4C1299KCZAD) && !defined (PART_TM4C1299NCZAD) && \
+ !defined (PART_TM4C129CNCPDT) && !defined (PART_TM4C129CNCZAD) && \
+ !defined (PART_TM4C129DNCPDT) && !defined (PART_TM4C129DNCZAD) && \
+ !defined (PART_TM4C129EKCPDT) && !defined (PART_TM4C129ENCPDT) && \
+ !defined (PART_TM4C129ENCZAD) && !defined (PART_TM4C129LNCZAD) && \
+ !defined (PART_TM4C129XKCZAD) && !defined (PART_TM4C129XNCZAD)
#include "board.h"
#endif
-/* Including the device CMSIS header. Note, we are not using the definitions
- from this header because we need this file to be usable also from
- assembler source files. We verify that the info matches instead.*/
-#include "tm4c129x.h"
-
-#if !CORTEX_HAS_MPU != !__MPU_PRESENT
-#error "CMSIS __MPU_PRESENT mismatch"
-#endif
-
-#if !CORTEX_HAS_FPU != !__FPU_PRESENT
-#error "CMSIS __FPU_PRESENT mismatch"
-#endif
-
-#if CORTEX_PRIORITY_BITS != __NVIC_PRIO_BITS
-#error "CMSIS __NVIC_PRIO_BITS mismatch"
+typedef int IRQn_Type;
+
+#include "core_cm4.h"
+
+/* Including the TivaWare peripheral headers.*/
+#include "inc/hw_ints.h"
+#include "inc/hw_memmap.h"
+#include "inc/hw_types.h"
+#include "inc/hw_timer.h"
+#include "inc/hw_sysctl.h"
+#include "inc/hw_gpio.h"
+#include "inc/hw_uart.h"
+#include "inc/hw_timer.h"
+#include "inc/hw_emac.h"
+#include "inc/hw_i2c.h"
+#include "inc/hw_watchdog.h"
+#include "inc/hw_ssi.h"
+#include "inc/hw_udma.h"
+#include "inc/hw_pwm.h"
+#include "inc/hw_adc.h"
+
+#if CORTEX_NUM_VECTORS != ((((NUM_INTERRUPTS - 16) + 7) / 8) * 8)
+#error "TivaWare NUM_INTERRUPTS mismatch"
#endif
#endif /* !defined(_FROM_ASM_) */
-#endif /* _CMPARAMS_H_ */
+#endif /* CMPARAMS_H */
-/**
- * @}
- */
+/** @} */