aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA/TM4C129x
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/TIVA/TM4C129x')
-rw-r--r--os/hal/ports/TIVA/TM4C129x/hal_lld.c2
-rw-r--r--os/hal/ports/TIVA/TM4C129x/hal_lld.h2
-rw-r--r--os/hal/ports/TIVA/TM4C129x/platform.mk3
-rw-r--r--os/hal/ports/TIVA/TM4C129x/tiva_isr.h2
-rw-r--r--os/hal/ports/TIVA/TM4C129x/tiva_registry.h2
-rw-r--r--os/hal/ports/TIVA/TM4C129x/tm4c129x.h6
6 files changed, 10 insertions, 7 deletions
diff --git a/os/hal/ports/TIVA/TM4C129x/hal_lld.c b/os/hal/ports/TIVA/TM4C129x/hal_lld.c
index 4f2a968..60d6763 100644
--- a/os/hal/ports/TIVA/TM4C129x/hal_lld.c
+++ b/os/hal/ports/TIVA/TM4C129x/hal_lld.c
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014 Marco Veeneman
+ Copyright (C) 2014..2016 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/hal/ports/TIVA/TM4C129x/hal_lld.h b/os/hal/ports/TIVA/TM4C129x/hal_lld.h
index 9a8f690..e5c667d 100644
--- a/os/hal/ports/TIVA/TM4C129x/hal_lld.h
+++ b/os/hal/ports/TIVA/TM4C129x/hal_lld.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014 Marco Veeneman
+ Copyright (C) 2014..2016 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/hal/ports/TIVA/TM4C129x/platform.mk b/os/hal/ports/TIVA/TM4C129x/platform.mk
index 6f0c0df..b8363f3 100644
--- a/os/hal/ports/TIVA/TM4C129x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C129x/platform.mk
@@ -5,7 +5,8 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/hal_pal_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/hal_serial_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/hal_mac_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/hal_ext_lld.c
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/hal_ext_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/hal_wdg_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
diff --git a/os/hal/ports/TIVA/TM4C129x/tiva_isr.h b/os/hal/ports/TIVA/TM4C129x/tiva_isr.h
index b995c4f..255bfd6 100644
--- a/os/hal/ports/TIVA/TM4C129x/tiva_isr.h
+++ b/os/hal/ports/TIVA/TM4C129x/tiva_isr.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014 Marco Veeneman
+ Copyright (C) 2014..2016 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/hal/ports/TIVA/TM4C129x/tiva_registry.h b/os/hal/ports/TIVA/TM4C129x/tiva_registry.h
index e38ee51..5815351 100644
--- a/os/hal/ports/TIVA/TM4C129x/tiva_registry.h
+++ b/os/hal/ports/TIVA/TM4C129x/tiva_registry.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014 Marco Veeneman
+ Copyright (C) 2014..2016 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/os/hal/ports/TIVA/TM4C129x/tm4c129x.h b/os/hal/ports/TIVA/TM4C129x/tm4c129x.h
index 462a14f..5a5f4f2 100644
--- a/os/hal/ports/TIVA/TM4C129x/tm4c129x.h
+++ b/os/hal/ports/TIVA/TM4C129x/tm4c129x.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014 Marco Veeneman
+ Copyright (C) 2014..2016 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -862,7 +862,7 @@ typedef struct
__IO uint32_t TEST; /**< Test */
__I uint32_t _RESERVED1[505];/**< Reserved */
__IO uint32_t LOCK; /**< Lock */
-} WATCHDOG_TypeDef;
+} WDG_TypeDef;
/**
* @brief Ethernet peripheral
@@ -1080,6 +1080,8 @@ typedef struct {
#define GPT5 ((GPT_TypeDef *) GPT5_BASE)
#define GPT6 ((GPT_TypeDef *) GPT6_BASE)
#define GPT7 ((GPT_TypeDef *) GPT7_BASE)
+#define WDT0 ((WDT_TypeDef *) WDT0_BASE)
+#define WDT1 ((WDT_TypeDef *) WDT1_BASE)
#define ADC0 ((ADC_TypeDef*) ADC0_BASE)
#define ADC1 ((ADC_TypeDef*) ADC1_BASE)
#define UART0 ((UART_TypeDef *) UART0_BASE)