aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/onewire/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/STM32F4xx/onewire/Makefile')
-rw-r--r--testhal/STM32/STM32F4xx/onewire/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/testhal/STM32/STM32F4xx/onewire/Makefile b/testhal/STM32/STM32F4xx/onewire/Makefile
index 999fb12..c07981c 100644
--- a/testhal/STM32/STM32F4xx/onewire/Makefile
+++ b/testhal/STM32/STM32F4xx/onewire/Makefile
@@ -173,10 +173,10 @@ AOPT =
TOPT = -mthumb -DTHUMB
# Define C warning options here
-CWARN = -Wall -Wextra -Wstrict-prototypes
+CWARN = -Wall -Wextra -Wstrict-prototypes -Wundef
# Define C++ warning options here
-CPPWARN = -Wall -Wextra
+CPPWARN = -Wall -Wextra -Wundef
#
# Compiler settings