aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheodore Ateba <tf.ateba@gmail.com>2017-08-13 14:18:30 +0000
committerTheodore Ateba <tf.ateba@gmail.com>2017-08-13 14:18:30 +0000
commit0879845f96744ce1c0548d3abeb55c392ef47c00 (patch)
treee5c0cbbe028f7bad6fc023c962bff3c6d463ae5b
parentcd06f9a246cf6c5d7009712d815dacf1632ffd64 (diff)
downloadChibiOS-0879845f96744ce1c0548d3abeb55c392ef47c00.tar.gz
ChibiOS-0879845f96744ce1c0548d3abeb55c392ef47c00.tar.bz2
ChibiOS-0879845f96744ce1c0548d3abeb55c392ef47c00.zip
Update the AVR Tiny Architecture.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10412 35acf78f-673a-0410-8e92-d51de3d6d3f4
-rw-r--r--os/hal/ports/AVR/TINY/ATTinyxxx/hal_lld.c (renamed from os/hal/ports/AVR/TINY/hal_lld.c)4
-rw-r--r--os/hal/ports/AVR/TINY/ATTinyxxx/hal_lld.h (renamed from os/hal/ports/AVR/TINY/hal_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/ATTinyxxx/platform.mk (renamed from os/hal/ports/AVR/TINY/platform.mk)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/GPIOv1/driver.mk (renamed from os/hal/ports/AVR/TINY/GPIOv1/driver.mk)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/GPIOv1/hal_pal_lld.c (renamed from os/hal/ports/AVR/TINY/GPIOv1/hal_pal_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/GPIOv1/hal_pal_lld.h (renamed from os/hal/ports/AVR/TINY/GPIOv1/hal_pal_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk (renamed from os/hal/ports/AVR/TINY/TIMv1/driver.mk)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_gpt_lld.c (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_gpt_lld.h (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_icu_lld.c (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_icu_lld.h (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_pwm_lld.c (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_pwm_lld.h (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_st_lld.c (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/hal_st_lld.h (renamed from os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/USARTv1/driver.mk (renamed from os/hal/ports/AVR/TINY/USARTv1/driver.mk)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/USARTv1/hal_serial_lld.c (renamed from os/hal/ports/AVR/TINY/USARTv1/hal_serial_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/USARTv1/hal_serial_lld.h (renamed from os/hal/ports/AVR/TINY/USARTv1/hal_serial_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/USARTv1/hal_uart_lld.c (renamed from os/hal/ports/AVR/TINY/USARTv1/hal_uart_lld.c)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/USARTv1/hal_uart_lld.h (renamed from os/hal/ports/AVR/TINY/USARTv1/hal_uart_lld.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/avr_pins.h (renamed from os/hal/ports/AVR/TINY/avr_pins.h)0
-rw-r--r--os/hal/ports/AVR/TINY/LLD/avr_timers.h (renamed from os/hal/ports/AVR/TINY/avr_timers.h)0
22 files changed, 2 insertions, 2 deletions
diff --git a/os/hal/ports/AVR/TINY/hal_lld.c b/os/hal/ports/AVR/TINY/ATTinyxxx/hal_lld.c
index fef8b7084..be1e23cac 100644
--- a/os/hal/ports/AVR/TINY/hal_lld.c
+++ b/os/hal/ports/AVR/TINY/ATTinyxxx/hal_lld.c
@@ -15,8 +15,8 @@
*/
/**
- * @file hal_lld.c
- * @brief AVR HAL subsystem low level driver code.
+ * @file ATTinyxxx/hal_lld.c
+ * @brief AVR Tiny HAL subsystem low level driver code.
*
* @addtogroup HAL
* @{
diff --git a/os/hal/ports/AVR/TINY/hal_lld.h b/os/hal/ports/AVR/TINY/ATTinyxxx/hal_lld.h
index eca18ffc3..eca18ffc3 100644
--- a/os/hal/ports/AVR/TINY/hal_lld.h
+++ b/os/hal/ports/AVR/TINY/ATTinyxxx/hal_lld.h
diff --git a/os/hal/ports/AVR/TINY/platform.mk b/os/hal/ports/AVR/TINY/ATTinyxxx/platform.mk
index 9635f6267..9635f6267 100644
--- a/os/hal/ports/AVR/TINY/platform.mk
+++ b/os/hal/ports/AVR/TINY/ATTinyxxx/platform.mk
diff --git a/os/hal/ports/AVR/TINY/GPIOv1/driver.mk b/os/hal/ports/AVR/TINY/LLD/GPIOv1/driver.mk
index 6675bfaf9..6675bfaf9 100644
--- a/os/hal/ports/AVR/TINY/GPIOv1/driver.mk
+++ b/os/hal/ports/AVR/TINY/LLD/GPIOv1/driver.mk
diff --git a/os/hal/ports/AVR/TINY/GPIOv1/hal_pal_lld.c b/os/hal/ports/AVR/TINY/LLD/GPIOv1/hal_pal_lld.c
index 142247ce6..142247ce6 100644
--- a/os/hal/ports/AVR/TINY/GPIOv1/hal_pal_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/GPIOv1/hal_pal_lld.c
diff --git a/os/hal/ports/AVR/TINY/GPIOv1/hal_pal_lld.h b/os/hal/ports/AVR/TINY/LLD/GPIOv1/hal_pal_lld.h
index 68694f9b0..68694f9b0 100644
--- a/os/hal/ports/AVR/TINY/GPIOv1/hal_pal_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/GPIOv1/hal_pal_lld.h
diff --git a/os/hal/ports/AVR/TINY/TIMv1/driver.mk b/os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk
index 982db5635..982db5635 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/driver.mk
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.c b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_gpt_lld.c
index 6ccc7cadd..6ccc7cadd 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_gpt_lld.c
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.h b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_gpt_lld.h
index 0cd26e662..0cd26e662 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_gpt_lld.h
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.c b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_icu_lld.c
index 74ceffe64..74ceffe64 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_icu_lld.c
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.h b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_icu_lld.h
index d9a67ae5a..d9a67ae5a 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_icu_lld.h
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.c b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_pwm_lld.c
index edd112e6d..edd112e6d 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_pwm_lld.c
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.h b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_pwm_lld.h
index 39dffbce8..39dffbce8 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_pwm_lld.h
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.c b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_st_lld.c
index 4732ec7dd..4732ec7dd 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_st_lld.c
diff --git a/os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.h b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_st_lld.h
index a5b58e693..a5b58e693 100644
--- a/os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/hal_st_lld.h
diff --git a/os/hal/ports/AVR/TINY/USARTv1/driver.mk b/os/hal/ports/AVR/TINY/LLD/USARTv1/driver.mk
index 7a90004e6..7a90004e6 100644
--- a/os/hal/ports/AVR/TINY/USARTv1/driver.mk
+++ b/os/hal/ports/AVR/TINY/LLD/USARTv1/driver.mk
diff --git a/os/hal/ports/AVR/TINY/USARTv1/hal_serial_lld.c b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_serial_lld.c
index de5143551..de5143551 100644
--- a/os/hal/ports/AVR/TINY/USARTv1/hal_serial_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_serial_lld.c
diff --git a/os/hal/ports/AVR/TINY/USARTv1/hal_serial_lld.h b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_serial_lld.h
index be53a0487..be53a0487 100644
--- a/os/hal/ports/AVR/TINY/USARTv1/hal_serial_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_serial_lld.h
diff --git a/os/hal/ports/AVR/TINY/USARTv1/hal_uart_lld.c b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_uart_lld.c
index 1006e1509..1006e1509 100644
--- a/os/hal/ports/AVR/TINY/USARTv1/hal_uart_lld.c
+++ b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_uart_lld.c
diff --git a/os/hal/ports/AVR/TINY/USARTv1/hal_uart_lld.h b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_uart_lld.h
index 587b2be19..587b2be19 100644
--- a/os/hal/ports/AVR/TINY/USARTv1/hal_uart_lld.h
+++ b/os/hal/ports/AVR/TINY/LLD/USARTv1/hal_uart_lld.h
diff --git a/os/hal/ports/AVR/TINY/avr_pins.h b/os/hal/ports/AVR/TINY/LLD/avr_pins.h
index b98ce2574..b98ce2574 100644
--- a/os/hal/ports/AVR/TINY/avr_pins.h
+++ b/os/hal/ports/AVR/TINY/LLD/avr_pins.h
diff --git a/os/hal/ports/AVR/TINY/avr_timers.h b/os/hal/ports/AVR/TINY/LLD/avr_timers.h
index 42c275e20..42c275e20 100644
--- a/os/hal/ports/AVR/TINY/avr_timers.h
+++ b/os/hal/ports/AVR/TINY/LLD/avr_timers.h