diff options
author | Giovanni Di Sirio <gdisirio@gmail.com> | 2019-01-02 11:58:58 +0000 |
---|---|---|
committer | Giovanni Di Sirio <gdisirio@gmail.com> | 2019-01-02 11:58:58 +0000 |
commit | 78058faf4d33e9800f5f7841d27a10c87289994c (patch) | |
tree | d3e6788d16b29b2016064a6b659a085824a27ad9 | |
parent | d5635adecc959228fefce27610f211087fefd87f (diff) | |
download | ChibiOS-78058faf4d33e9800f5f7841d27a10c87289994c.tar.gz ChibiOS-78058faf4d33e9800f5f7841d27a10c87289994c.tar.bz2 ChibiOS-78058faf4d33e9800f5f7841d27a10c87289994c.zip |
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@12522 110e8d01-0319-4d1e-a829-52ad28d1bb01
-rw-r--r-- | demos/various/RT-ARM7-GENERIC/Makefile | 21 | ||||
-rw-r--r-- | readme.txt | 3 |
2 files changed, 9 insertions, 15 deletions
diff --git a/demos/various/RT-ARM7-GENERIC/Makefile b/demos/various/RT-ARM7-GENERIC/Makefile index c70eaed41..4954f8323 100644 --- a/demos/various/RT-ARM7-GENERIC/Makefile +++ b/demos/various/RT-ARM7-GENERIC/Makefile @@ -111,6 +111,8 @@ PROJECT = ch # Imported source files and paths
CHIBIOS = ../../..
+# Licensing files.
+include $(CHIBIOS)/os/license/license.mk
# Startup files.
include $(CHIBIOS)/os/common/startup/ARM/compilers/GCC/mk/startup_lpc214x.mk
# HAL-OSAL files (optional).
@@ -131,19 +133,13 @@ LDSCRIPT= $(STARTUPLD)/LPC2148.ld # C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(STARTUPSRC) \
- $(KERNSRC) \
- $(PORTSRC) \
- $(OSALSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC) \
+CSRC = $(ALLCSRC) \
$(TESTSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(ALLCPPSRC)
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -166,13 +162,10 @@ TCSRC = TCPPSRC =
# List ASM source files here
-ASMSRC =
-ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
+ASMSRC = $(ALLASMSRC)
+ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(CHIBIOS)/os/license \
- $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various
+INCDIR = $(CONFDIR) $(ALLINC) $(TESTINC)
#
# Project, sources and paths
diff --git a/readme.txt b/readme.txt index ba75ca382..c39167720 100644 --- a/readme.txt +++ b/readme.txt @@ -75,7 +75,8 @@ *****************************************************************************
*** Next ***
-- NEW: STM32H7xx and STM32L4+ ports reworked to support dynamic DMA allocation.
+- NEW: STM32H7xx and STM32L4+ ports reworked to support dynamic DMA
+ allocation. Updated all drivers to use the new DMA API.
- NEW: Both DMAv1 and DMAv2 have been reworked to support DMAMUX, DMAv3 has
been removed. In addition, both drivers are now able to support dynamic
channel allocation.
|