diff options
author | gdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4> | 2010-05-04 19:55:26 +0000 |
---|---|---|
committer | gdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4> | 2010-05-04 19:55:26 +0000 |
commit | 9d256a8b42e827204c80205cc47a982d5c5c7b52 (patch) | |
tree | 46f78a654c8a23249d63e2fc0963feaf19705aef | |
parent | bc9d319ddb279f973404c2b1abf15ec1091bd891 (diff) | |
download | ChibiOS-9d256a8b42e827204c80205cc47a982d5c5c7b52.tar.gz ChibiOS-9d256a8b42e827204c80205cc47a982d5c5c7b52.tar.bz2 ChibiOS-9d256a8b42e827204c80205cc47a982d5c5c7b52.zip |
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@1903 35acf78f-673a-0410-8e92-d51de3d6d3f4
-rw-r--r-- | demos/ARM7-AT91SAM7X-GCC/Makefile | 3 | ||||
-rw-r--r-- | demos/ARM7-AT91SAM7X-LWIP-GCC/Makefile | 3 | ||||
-rw-r--r-- | demos/ARM7-AT91SAM7X-UIP-GCC/Makefile | 3 | ||||
-rw-r--r-- | demos/ARM7-LPC214x-FATFS-GCC/Makefile | 3 | ||||
-rw-r--r-- | demos/ARM7-LPC214x-G++/Makefile | 3 | ||||
-rw-r--r-- | demos/ARM7-LPC214x-GCC/Makefile | 3 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103-FATFS-GCC/Makefile | 3 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103-GCC/Makefile | 3 | ||||
-rw-r--r-- | readme.txt | 5 | ||||
-rw-r--r-- | test/testpools.c | 1 |
10 files changed, 22 insertions, 8 deletions
diff --git a/demos/ARM7-AT91SAM7X-GCC/Makefile b/demos/ARM7-AT91SAM7X-GCC/Makefile index e43fdf7e8..f9db0679b 100644 --- a/demos/ARM7-AT91SAM7X-GCC/Makefile +++ b/demos/ARM7-AT91SAM7X-GCC/Makefile @@ -104,7 +104,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = arm7tdmi
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARM7-AT91SAM7X-LWIP-GCC/Makefile b/demos/ARM7-AT91SAM7X-LWIP-GCC/Makefile index f51cf1778..3890b27ed 100644 --- a/demos/ARM7-AT91SAM7X-LWIP-GCC/Makefile +++ b/demos/ARM7-AT91SAM7X-LWIP-GCC/Makefile @@ -114,7 +114,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = arm7tdmi
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile b/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile index 419506193..641cbdb76 100644 --- a/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile +++ b/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile @@ -118,7 +118,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = arm7tdmi
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARM7-LPC214x-FATFS-GCC/Makefile b/demos/ARM7-LPC214x-FATFS-GCC/Makefile index adc7d7d68..99ff790e9 100644 --- a/demos/ARM7-LPC214x-FATFS-GCC/Makefile +++ b/demos/ARM7-LPC214x-FATFS-GCC/Makefile @@ -110,7 +110,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = arm7tdmi
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARM7-LPC214x-G++/Makefile b/demos/ARM7-LPC214x-G++/Makefile index 14cd28728..0cc8f6e53 100644 --- a/demos/ARM7-LPC214x-G++/Makefile +++ b/demos/ARM7-LPC214x-G++/Makefile @@ -104,7 +104,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = arm7tdmi
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARM7-LPC214x-GCC/Makefile b/demos/ARM7-LPC214x-GCC/Makefile index a1056cbd7..99b7202cd 100644 --- a/demos/ARM7-LPC214x-GCC/Makefile +++ b/demos/ARM7-LPC214x-GCC/Makefile @@ -104,7 +104,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = arm7tdmi
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARMCM3-STM32F103-FATFS-GCC/Makefile b/demos/ARMCM3-STM32F103-FATFS-GCC/Makefile index 1094cf3ca..22e059a39 100644 --- a/demos/ARMCM3-STM32F103-FATFS-GCC/Makefile +++ b/demos/ARMCM3-STM32F103-FATFS-GCC/Makefile @@ -121,7 +121,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = cortex-m3
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/demos/ARMCM3-STM32F103-GCC/Makefile b/demos/ARMCM3-STM32F103-GCC/Makefile index 5284c7ad2..59949cd15 100644 --- a/demos/ARMCM3-STM32F103-GCC/Makefile +++ b/demos/ARMCM3-STM32F103-GCC/Makefile @@ -118,7 +118,8 @@ INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \ MCU = cortex-m3
-TRGT = arm-elf-
+#TRGT = arm-elf-
+TRGT = arm-none-eabi-
CC = $(TRGT)gcc
CPPC = $(TRGT)g++
# Enable loading with g++ only if you need C++ runtime support.
diff --git a/readme.txt b/readme.txt index 54600c1d4..f8acafaa5 100644 --- a/readme.txt +++ b/readme.txt @@ -79,6 +79,10 @@ can be easily added.
- CHANGE: Renamed the chCoreFree() function in chCoreStatus() because it
might be mistaken for a function that frees memory.
+- CHANGE: All ARM demos makefiles now defaults to arm-none-eabi- GNU
+ toolchains because the latest YAGARTO now uses that setting. It is still
+ possible to use arm-elf- toolchains by editing the TRGT variable in the
+ makefiles.
- Various documentation fixes, added an article covering debugging under
ChibiOS/RT, updated the article about interrupt handlers to cover also
fast interrupt sources.
@@ -86,6 +90,7 @@ - Added new test cases, now the coverage is again up to 100% except for the
debug module that would require triggering system terminating tests (panics),
the uncovered code is minimal and extremely simple anyway.
+- ChibiOS/RT has been successfully verified with the latest GCC 4.5.0.
*** 1.5.5 ***
- FIX: Removed some "dead" code in the old ARMv7-M files (there are new
diff --git a/test/testpools.c b/test/testpools.c index af4999547..fdd637768 100644 --- a/test/testpools.c +++ b/test/testpools.c @@ -62,6 +62,7 @@ static MEMORYPOOL_DECL(mp1, THD_WA_SIZE(THREADS_STACK_SIZE), NULL); static void *null_provider(size_t size) {
+ (void)size;
return NULL;
}
|