diff options
author | Giovanni Di Sirio <gdisirio@gmail.com> | 2018-10-07 11:59:35 +0000 |
---|---|---|
committer | Giovanni Di Sirio <gdisirio@gmail.com> | 2018-10-07 11:59:35 +0000 |
commit | dc7ae21c744272f7796386c4a8ad68cb41278359 (patch) | |
tree | 88072dc161b3c10ac53816fe825ff3bd2b992c3e | |
parent | 40932b20589b66407578a84eb573dd0bfc5395cd (diff) | |
download | ChibiOS-dc7ae21c744272f7796386c4a8ad68cb41278359.tar.gz ChibiOS-dc7ae21c744272f7796386c4a8ad68cb41278359.tar.bz2 ChibiOS-dc7ae21c744272f7796386c4a8ad68cb41278359.zip |
Renamed for consistency.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@12346 110e8d01-0319-4d1e-a829-52ad28d1bb01
-rw-r--r-- | os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.c (renamed from os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.c) | 2 | ||||
-rw-r--r-- | os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.h (renamed from os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.h) | 6 | ||||
-rw-r--r-- | os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.mk (renamed from os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.mk) | 4 | ||||
-rw-r--r-- | os/hal/lib/complex/serial_nor/hal_serial_nor.c (renamed from os/hal/lib/complex/serial_nor/serial_nor.c) | 2 | ||||
-rw-r--r-- | os/hal/lib/complex/serial_nor/hal_serial_nor.h (renamed from os/hal/lib/complex/serial_nor/serial_nor.h) | 8 | ||||
-rw-r--r-- | os/lib/include/chlib.h | 14 | ||||
-rw-r--r-- | os/license/chcustomer.h | 2 | ||||
-rw-r--r-- | testhal/STM32/multi/WSPI-MFS/.cproject | 1 | ||||
-rw-r--r-- | testhal/STM32/multi/WSPI-MFS/main.c | 2 | ||||
-rw-r--r-- | testhal/STM32/multi/WSPI-MFS/make/stm32l476_discovery.make | 2 |
10 files changed, 22 insertions, 21 deletions
diff --git a/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.c b/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.c index 5f320ebc8..1bba8f99a 100644 --- a/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.c +++ b/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.c @@ -26,7 +26,7 @@ #include <string.h>
#include "hal.h"
-#include "serial_nor.h"
+#include "hal_serial_nor.h"
/*===========================================================================*/
/* Driver local definitions. */
diff --git a/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.h b/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.h index 8ae3bae13..22b024b95 100644 --- a/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.h +++ b/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.h @@ -23,8 +23,8 @@ * @{
*/
-#ifndef FLASH_DEVICE_H
-#define FLASH_DEVICE_H
+#ifndef HAL_FLASH_DEVICE_H
+#define HAL_FLASH_DEVICE_H
/*===========================================================================*/
/* Driver constants. */
@@ -201,7 +201,7 @@ extern "C" { }
#endif
-#endif /* FLASH_DEVICE_H */
+#endif /* HAL_FLASH_DEVICE_H */
/** @} */
diff --git a/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.mk b/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.mk index 07103fe29..c333513dd 100644 --- a/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.mk +++ b/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.mk @@ -1,7 +1,7 @@ # List of all the Micron N25Q device files.
N25QSRC := $(CHIBIOS)/os/hal/lib/peripherals/flash/hal_flash.c \
- $(CHIBIOS)/os/hal/lib/complex/serial_nor/serial_nor.c \
- $(CHIBIOS)/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.c
+ $(CHIBIOS)/os/hal/lib/complex/serial_nor/hal_serial_nor.c \
+ $(CHIBIOS)/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.c
# Required include directories
N25QINC := $(CHIBIOS)/os/hal/lib/peripherals/flash \
diff --git a/os/hal/lib/complex/serial_nor/serial_nor.c b/os/hal/lib/complex/serial_nor/hal_serial_nor.c index 6e512fcc3..b21d09694 100644 --- a/os/hal/lib/complex/serial_nor/serial_nor.c +++ b/os/hal/lib/complex/serial_nor/hal_serial_nor.c @@ -24,7 +24,7 @@ */
#include "hal.h"
-#include "serial_nor.h"
+#include "hal_serial_nor.h"
/*===========================================================================*/
/* Driver local definitions. */
diff --git a/os/hal/lib/complex/serial_nor/serial_nor.h b/os/hal/lib/complex/serial_nor/hal_serial_nor.h index 62c25a1ba..6be8e8e0c 100644 --- a/os/hal/lib/complex/serial_nor/serial_nor.h +++ b/os/hal/lib/complex/serial_nor/hal_serial_nor.h @@ -23,8 +23,8 @@ * @{
*/
-#ifndef SERIAL_NOR_H
-#define SERIAL_NOR_H
+#ifndef HAL_SERIAL_NOR_H
+#define HAL_SERIAL_NOR_H
#include "hal_flash.h"
@@ -192,9 +192,9 @@ extern "C" { #endif
/* Device-specific implementations.*/
-#include "flash_device.h"
+#include "hal_flash_device.h"
-#endif /* SERIAL_NOR_H */
+#endif /* HAL_SERIAL_NOR_H */
/** @} */
diff --git a/os/lib/include/chlib.h b/os/lib/include/chlib.h index 1097c8e15..495d03643 100644 --- a/os/lib/include/chlib.h +++ b/os/lib/include/chlib.h @@ -38,7 +38,7 @@ /**
* @brief ChibiOS/LIB identification macro.
*/
-#define _CHIBIOS_LIB_
+#define _CHIBIOS_OSLIB_
/**
* @brief Stable release flag.
@@ -138,11 +138,11 @@ #endif
/* License checks.*/
-#if !defined(CH_CUSTOMER_LIC_LIB) || !defined(CH_LICENSE_FEATURES)
+#if !defined(CH_CUSTOMER_LIC_OSLIB) || !defined(CH_LICENSE_FEATURES)
#error "malformed chlicense.h"
#endif
-#if CH_CUSTOMER_LIC_LIB== FALSE
+#if CH_CUSTOMER_LIC_OSLIB== FALSE
#error "ChibiOS/LIB not licensed"
#endif
@@ -153,7 +153,7 @@ #endif
/* Restrictions in basic and intermediate modes.*/
-#if (CH_CUSTOMER_LIC_LIB == FALSE) || \
+#if (CH_CUSTOMER_LIC_OSLIB == FALSE) || \
(CH_LICENSE_FEATURES == CH_FEATURES_INTERMEDIATE) || \
(CH_LICENSE_FEATURES == CH_FEATURES_BASIC)
@@ -162,12 +162,12 @@ #define CH_CFG_USE_FACTORY FALSE
-#endif /* (CH_CUSTOMER_LIC_LIB == FALSE) ||
+#endif /* (CH_CUSTOMER_LIC_OSLIB == FALSE) ||
(CH_LICENSE_FEATURES == CH_FEATURES_INTERMEDIATE) ||
(CH_LICENSE_FEATURES == CH_FEATURES_BASIC) */
/* Restrictions in basic mode.*/
-#if (CH_CUSTOMER_LIC_LIB == FALSE) || \
+#if (CH_CUSTOMER_LIC_OSLIB == FALSE) || \
(CH_LICENSE_FEATURES == CH_FEATURES_BASIC)
/* Restricted subsystems.*/
@@ -183,7 +183,7 @@ #define CH_CFG_USE_OBJ_FIFOS FALSE
#define CH_CFG_USE_PIPES FALSE
-#endif /* (CH_CUSTOMER_LIC_LIB == FALSE) ||
+#endif /* (CH_CUSTOMER_LIC_OSLIB == FALSE) ||
(CH_LICENSE_FEATURES == CH_FEATURES_BASIC) */
/*===========================================================================*/
diff --git a/os/license/chcustomer.h b/os/license/chcustomer.h index 61aed864e..0c0f8cb16 100644 --- a/os/license/chcustomer.h +++ b/os/license/chcustomer.h @@ -60,7 +60,7 @@ */
#define CH_CUSTOMER_LIC_RT TRUE
#define CH_CUSTOMER_LIC_NIL TRUE
-#define CH_CUSTOMER_LIC_LIB TRUE
+#define CH_CUSTOMER_LIC_OSLIB TRUE
#define CH_CUSTOMER_LIC_EX TRUE
#define CH_CUSTOMER_LIC_PORT_CM0 TRUE
#define CH_CUSTOMER_LIC_PORT_CM3 TRUE
diff --git a/testhal/STM32/multi/WSPI-MFS/.cproject b/testhal/STM32/multi/WSPI-MFS/.cproject index a950bac3f..5052dd0dd 100644 --- a/testhal/STM32/multi/WSPI-MFS/.cproject +++ b/testhal/STM32/multi/WSPI-MFS/.cproject @@ -78,6 +78,7 @@ <configuration configurationName="Default">
<resource resourceType="PROJECT" workspacePath="/STM32-WSPI-MFS"/>
</configuration>
+ <configuration configurationName="Build for STM32L476-Discovery"/>
</storageModule>
<storageModule moduleId="scannerConfiguration">
<autodiscovery enabled="true" problemReportingEnabled="true" selectedProfileId=""/>
diff --git a/testhal/STM32/multi/WSPI-MFS/main.c b/testhal/STM32/multi/WSPI-MFS/main.c index 3de5be345..eb964184b 100644 --- a/testhal/STM32/multi/WSPI-MFS/main.c +++ b/testhal/STM32/multi/WSPI-MFS/main.c @@ -19,7 +19,7 @@ #include "ch.h"
#include "hal.h"
-#include "serial_nor.h"
+#include "hal_serial_nor.h"
#include "mfs.h"
#include "mfs_test_root.h"
diff --git a/testhal/STM32/multi/WSPI-MFS/make/stm32l476_discovery.make b/testhal/STM32/multi/WSPI-MFS/make/stm32l476_discovery.make index 067ab9f04..ad212eca6 100644 --- a/testhal/STM32/multi/WSPI-MFS/make/stm32l476_discovery.make +++ b/testhal/STM32/multi/WSPI-MFS/make/stm32l476_discovery.make @@ -113,7 +113,7 @@ include $(CHIBIOS)/tools/mk/autobuild.mk # Other files (optional).
include $(CHIBIOS)/test/lib/test.mk
include $(CHIBIOS)/test/mfs/mfs_test.mk
-include $(CHIBIOS)/os/hal/lib/complex/serial_nor/devices/micron_n25q/flash_device.mk
+include $(CHIBIOS)/os/hal/lib/complex/serial_nor/devices/micron_n25q/hal_flash_device.mk
include $(CHIBIOS)/os/hal/lib/complex/mfs/mfs.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
|