aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-11-19 08:02:25 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-11-19 08:02:25 +0000
commite877388d6da00a2f52ab1661a642f9e779022b15 (patch)
treea6ee11f36f5c28402184ec259406ca290ba2bf2f
parent78073b2ee3d46e5070f2e00c38ae681c87365a5f (diff)
downloadChibiOS-e877388d6da00a2f52ab1661a642f9e779022b15.tar.gz
ChibiOS-e877388d6da00a2f52ab1661a642f9e779022b15.tar.bz2
ChibiOS-e877388d6da00a2f52ab1661a642f9e779022b15.zip
Fixed bug #905.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@11034 35acf78f-673a-0410-8e92-d51de3d6d3f4
-rw-r--r--os/hal/ports/STM32/STM32F0xx/stm32_registry.h2
-rw-r--r--readme.txt2
2 files changed, 3 insertions, 1 deletions
diff --git a/os/hal/ports/STM32/STM32F0xx/stm32_registry.h b/os/hal/ports/STM32/STM32F0xx/stm32_registry.h
index 12e79b0a5..02e93089f 100644
--- a/os/hal/ports/STM32/STM32F0xx/stm32_registry.h
+++ b/os/hal/ports/STM32/STM32F0xx/stm32_registry.h
@@ -1799,7 +1799,7 @@
STM32_DMA_STREAM_ID_MSK(2, 3))
#define STM32_DAC1_CH1_DMA_CHN 0x00000100
-#define STM32_HAS_DAC1_CH2 FALSE
+#define STM32_HAS_DAC1_CH2 TRUE
#define STM32_DAC1_CH2_DMA_MSK (STM32_DMA_STREAM_ID_MSK(1, 4) |\
STM32_DMA_STREAM_ID_MSK(2, 4))
#define STM32_DAC1_CH2_DMA_CHN 0x00001000
diff --git a/readme.txt b/readme.txt
index e49032955..5cf5c6b86 100644
--- a/readme.txt
+++ b/readme.txt
@@ -153,6 +153,8 @@
dependencies and configuration directories. This makes possible
to have multiple non-conflicting makefiles in the same project.
Updated the various platform.mk implementing "smart build" mode.
+- HAL: Fixed DAC CH2 marked as not present in STM32F091 registry (bug #905)
+ (backported to 17.6.4 and 16.1.10).
- HAL: Fixed ADC does not build on STM32F030 (bug #903)(backported to 17.6.4).
- LIB: Fixed typo for function evtStop (bug #897)(backported to 17.6.4
and 16.1.10).