aboutsummaryrefslogtreecommitdiffstats
path: root/demos/ARMCM3-STM32F103-GCC/Makefile
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2009-07-18 12:55:22 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2009-07-18 12:55:22 +0000
commit4849f800cf3ad6ba07ed785c5198d21917e63996 (patch)
tree2648e965b121862e3c72c37e09d375d8f0ed9114 /demos/ARMCM3-STM32F103-GCC/Makefile
parent5ed3eb8eb99eecad0138843118e2e6d39a3189f8 (diff)
downloadChibiOS-4849f800cf3ad6ba07ed785c5198d21917e63996.tar.gz
ChibiOS-4849f800cf3ad6ba07ed785c5198d21917e63996.tar.bz2
ChibiOS-4849f800cf3ad6ba07ed785c5198d21917e63996.zip
Added ST firmware library files to the STM32 demo in order to make things easier to users.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@1067 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'demos/ARMCM3-STM32F103-GCC/Makefile')
-rw-r--r--demos/ARMCM3-STM32F103-GCC/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/demos/ARMCM3-STM32F103-GCC/Makefile b/demos/ARMCM3-STM32F103-GCC/Makefile
index fc36a80d2..3ffda1a1c 100644
--- a/demos/ARMCM3-STM32F103-GCC/Makefile
+++ b/demos/ARMCM3-STM32F103-GCC/Makefile
@@ -196,9 +196,7 @@ ULIBS =
ifeq ($(USE_FWLIB),yes)
include ./stm32lib/stm32lib.mk
CSRC += ${STM32SRC}
- # The thing generates a lot of aliasing warnings, this disables an
- # optimization and the warning disappears, the code is a bit larger however.
- USE_OPT += -fno-strict-aliasing
+ USE_OPT += -DUSE_STDPERIPH_DRIVER
endif
include ../../ports/ARM/rules.mk