diff options
author | Giovanni Di Sirio <gdisirio@gmail.com> | 2017-10-16 15:09:11 +0000 |
---|---|---|
committer | Giovanni Di Sirio <gdisirio@gmail.com> | 2017-10-16 15:09:11 +0000 |
commit | eb6b6685f09fbc4822492a1db9eaa367f46c657c (patch) | |
tree | e6b73b5865ff9559fd766a38054cbffc2e9466a3 /demos/STM32 | |
parent | 6bbfd2126f0cd20c733b78682d322250d8223d93 (diff) | |
download | ChibiOS-eb6b6685f09fbc4822492a1db9eaa367f46c657c.tar.gz ChibiOS-eb6b6685f09fbc4822492a1db9eaa367f46c657c.tar.bz2 ChibiOS-eb6b6685f09fbc4822492a1db9eaa367f46c657c.zip |
Enhancements in the test engine, not finished.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10835 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'demos/STM32')
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/Makefile | 2 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/main.c | 7 |
2 files changed, 5 insertions, 4 deletions
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile index 94853d1b3..f77f31794 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile @@ -103,7 +103,7 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-#include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/rt/test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F746xG.ld
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/main.c b/demos/STM32/RT-STM32F746G-DISCOVERY/main.c index 5199ddf37..56e339001 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/main.c +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/main.c @@ -16,7 +16,8 @@ #include "ch.h"
#include "hal.h"
-//#include "ch_test.h"
+#include "ch_test.h"
+#include "rt_test_root.h"
/*
* This is a periodic thread that does absolutely nothing except flashing
@@ -71,8 +72,8 @@ int main(void) { * sleeping in a loop and check the button state.
*/
while (true) {
-// if (palReadLine(LINE_BUTTON_USER))
-// test_execute((BaseSequentialStream *)&SD1);
+ if (palReadLine(LINE_BUTTON_USER))
+ test_execute((BaseSequentialStream *)&SD1, rt_test_suite);
chThdSleepMilliseconds(2000);
}
}
|