diff options
author | Giovanni Di Sirio <gdisirio@gmail.com> | 2018-10-07 12:06:42 +0000 |
---|---|---|
committer | Giovanni Di Sirio <gdisirio@gmail.com> | 2018-10-07 12:06:42 +0000 |
commit | 8bd7175893bc05ed967b44da1977d6c5108c6afa (patch) | |
tree | fcf0cdad790783413636d0db228af534013616d7 /os/hal/lib/complex/mfs | |
parent | dc7ae21c744272f7796386c4a8ad68cb41278359 (diff) | |
download | ChibiOS-8bd7175893bc05ed967b44da1977d6c5108c6afa.tar.gz ChibiOS-8bd7175893bc05ed967b44da1977d6c5108c6afa.tar.bz2 ChibiOS-8bd7175893bc05ed967b44da1977d6c5108c6afa.zip |
Renamed for consistency.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@12347 110e8d01-0319-4d1e-a829-52ad28d1bb01
Diffstat (limited to 'os/hal/lib/complex/mfs')
-rw-r--r-- | os/hal/lib/complex/mfs/hal_mfs.c (renamed from os/hal/lib/complex/mfs/mfs.c) | 6 | ||||
-rw-r--r-- | os/hal/lib/complex/mfs/hal_mfs.h (renamed from os/hal/lib/complex/mfs/mfs.h) | 10 | ||||
-rw-r--r-- | os/hal/lib/complex/mfs/hal_mfs.mk (renamed from os/hal/lib/complex/mfs/mfs.mk) | 2 |
3 files changed, 9 insertions, 9 deletions
diff --git a/os/hal/lib/complex/mfs/mfs.c b/os/hal/lib/complex/mfs/hal_mfs.c index 32ae2432a..d37326134 100644 --- a/os/hal/lib/complex/mfs/mfs.c +++ b/os/hal/lib/complex/mfs/hal_mfs.c @@ -18,7 +18,7 @@ */
/**
- * @file mfs.c
+ * @file hal_mfs.c
* @brief Managed Flash Storage module code.
* @details This module manages a flash partition as a generic storage where
* arbitrary data records can be created, updated, deleted and
@@ -30,7 +30,7 @@ * banks (where possible) caused by power loss during operations.
* Both operations are transparent to the user.
*
- * @addtogroup MFS
+ * @addtogroup HAL_MFS
* @{
*/
@@ -38,7 +38,7 @@ #include "hal.h"
-#include "mfs.h"
+#include "hal_mfs.h"
/*===========================================================================*/
/* Driver local definitions. */
diff --git a/os/hal/lib/complex/mfs/mfs.h b/os/hal/lib/complex/mfs/hal_mfs.h index d41dcf9bf..19c9b195f 100644 --- a/os/hal/lib/complex/mfs/mfs.h +++ b/os/hal/lib/complex/mfs/hal_mfs.h @@ -18,15 +18,15 @@ */
/**
- * @file mfs.h
+ * @file hal_mfs.h
* @brief Managed Flash Storage module header.
*
- * @addtogroup MFS
+ * @addtogroup HAL_MFS
* @{
*/
-#ifndef MFS_H
-#define MFS_H
+#ifndef HAL_MFS_H
+#define HAL_MFS_H
#include "hal_flash.h"
@@ -364,7 +364,7 @@ extern "C" { }
#endif
-#endif /* MFS_H */
+#endif /* HAL_MFS_H */
/** @} */
diff --git a/os/hal/lib/complex/mfs/mfs.mk b/os/hal/lib/complex/mfs/hal_mfs.mk index b1b67bb61..6448737b8 100644 --- a/os/hal/lib/complex/mfs/mfs.mk +++ b/os/hal/lib/complex/mfs/hal_mfs.mk @@ -1,5 +1,5 @@ # List of all the MFS subsystem files.
-MFSSRC := $(CHIBIOS)/os/hal/lib/complex/mfs/mfs.c
+MFSSRC := $(CHIBIOS)/os/hal/lib/complex/mfs/hal_mfs.c
# Required include directories
MFSINC := $(CHIBIOS)/os/hal/lib/complex/mfs
|