diff options
author | gdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4> | 2012-12-12 11:29:01 +0000 |
---|---|---|
committer | gdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4> | 2012-12-12 11:29:01 +0000 |
commit | e4c5ac420566026e6b819bd10956156e453f0842 (patch) | |
tree | 5436be60537918c1c2e4a24f196585cdf3dee129 /os/hal/platforms/SPC563Mxx | |
parent | 78e38625943412e0849142b757ced4aa99b9d7d9 (diff) | |
download | ChibiOS-e4c5ac420566026e6b819bd10956156e453f0842.tar.gz ChibiOS-e4c5ac420566026e6b819bd10956156e453f0842.tar.bz2 ChibiOS-e4c5ac420566026e6b819bd10956156e453f0842.zip |
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@4906 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/platforms/SPC563Mxx')
-rw-r--r-- | os/hal/platforms/SPC563Mxx/hal_lld.h | 4 | ||||
-rw-r--r-- | os/hal/platforms/SPC563Mxx/platform.mk | 4 |
2 files changed, 4 insertions, 4 deletions
diff --git a/os/hal/platforms/SPC563Mxx/hal_lld.h b/os/hal/platforms/SPC563Mxx/hal_lld.h index bda58ed00..e7d532945 100644 --- a/os/hal/platforms/SPC563Mxx/hal_lld.h +++ b/os/hal/platforms/SPC563Mxx/hal_lld.h @@ -186,7 +186,7 @@ /**
* @brief PLL output clock.
*/
-#define SPC5_PLLCLK ((EXTCLK / (SPC5_CLK_PREDIV + 1)) * SPC5_CLK_MFD)
+#define SPC5_PLLCLK ((SPC5_XOSC_CLK / (SPC5_CLK_PREDIV + 1)) * SPC5_CLK_MFD)
#if (SPC5_PLLCLK < 256000000) || (SPC5_PLLCLK > 512000000)
#error "VCO frequency out of the acceptable range (256...512)"
@@ -198,7 +198,7 @@ #if !SPC5_CLK_BYPASS || defined(__DOXYGEN__)
#define SPC5_SYSCLK (SPC5_PLLCLK / (1 << (SPC5_CLK_RFD + 1)))
#else
-#define SPC5_SYSCLK EXTCLK
+#define SPC5_SYSCLK SPC5_XOSC_CLK
#endif
#if (SPC5_SYSCLK > 80000000) && !SPC5_ALLOW_OVERCLOCK
diff --git a/os/hal/platforms/SPC563Mxx/platform.mk b/os/hal/platforms/SPC563Mxx/platform.mk index d70bad232..04e9a9739 100644 --- a/os/hal/platforms/SPC563Mxx/platform.mk +++ b/os/hal/platforms/SPC563Mxx/platform.mk @@ -1,9 +1,9 @@ # List of all the SPC56x platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/platforms/SPC563Mxx/hal_lld.c \
${CHIBIOS}/os/hal/platforms/SPC5xx/ESCI_v1/serial_lld.c \
- ${CHIBIOS}/os/hal/platforms/SPC5xx/SIUL_v1/pal_lld.c
+ ${CHIBIOS}/os/hal/platforms/SPC5xx/SIU_v1/pal_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/platforms/SPC563Mxx \
${CHIBIOS}/os/hal/platforms/SPC5xx/ESCI_v1 \
- ${CHIBIOS}/os/hal/platforms/SPC5xx/SIUL_v1
+ ${CHIBIOS}/os/hal/platforms/SPC5xx/SIU_v1
|