diff options
author | edolomb <none@example.com> | 2018-03-16 16:36:47 +0000 |
---|---|---|
committer | edolomb <none@example.com> | 2018-03-16 16:36:47 +0000 |
commit | 259f9cace1827a20d76c93a909b57e847d2ff9a0 (patch) | |
tree | 35045ba09bc32e4ab891e0df870143c2967759bb /testhal/ATSAMA5D2/RTC | |
parent | 7b6a255a2c1a8e0ef6e2a1448e796f72e2cf78c3 (diff) | |
download | ChibiOS-259f9cace1827a20d76c93a909b57e847d2ff9a0.tar.gz ChibiOS-259f9cace1827a20d76c93a909b57e847d2ff9a0.tar.bz2 ChibiOS-259f9cace1827a20d76c93a909b57e847d2ff9a0.zip |
- Updated demos
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@11782 110e8d01-0319-4d1e-a829-52ad28d1bb01
Diffstat (limited to 'testhal/ATSAMA5D2/RTC')
-rw-r--r-- | testhal/ATSAMA5D2/RTC/Makefile | 27 | ||||
-rw-r--r-- | testhal/ATSAMA5D2/RTC/main.c | 4 |
2 files changed, 11 insertions, 20 deletions
diff --git a/testhal/ATSAMA5D2/RTC/Makefile b/testhal/ATSAMA5D2/RTC/Makefile index bd31b30ca..021fceb72 100644 --- a/testhal/ATSAMA5D2/RTC/Makefile +++ b/testhal/ATSAMA5D2/RTC/Makefile @@ -108,9 +108,14 @@ endif # Define project name here
PROJECT = ch
+BUILDDIR := ./build
+DEPDIR := ./.dep
# Imported source files and paths
CHIBIOS = ../../..
+
+# Licensing files.
+include $(CHIBIOS)/os/license/license.mk
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCAx-TZ/compilers/GCC/mk/startup_sama5d2.mk
# HAL-OSAL files (optional).
@@ -125,6 +130,7 @@ include $(CHIBIOS)/os/common/ports/ARMCAx-TZ/compilers/GCC/mk/port_generic.mk #include $(CHIBIOS)/test/lib/test.mk
#include $(CHIBIOS)/test/rt/rt_test.mk
#include $(CHIBIOS)/test/oslib/oslib_test.mk
+include $(CHIBIOS)/os/hal/lib/streams/streams.mk
# Define linker script file here
#LDSCRIPT= $(STARTUPLD)/SAMA5D2.ld
@@ -133,21 +139,13 @@ LDSCRIPT= $(STARTUPLD)/SAMA5D2ddr.ld # C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(STARTUPSRC) \
- $(KERNSRC) \
- $(PORTSRC) \
- $(OSALSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC) \
- $(TESTSRC) \
- $(CHIBIOS)/os/hal/lib/streams/chprintf.c \
+CSRC = $(ALLCSRC) \
$(CHIBIOS)/os/various/syscalls.c \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(ALLCPPSRC)
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -170,13 +168,10 @@ TCSRC = TCPPSRC =
# List ASM source files here
-ASMSRC =
-ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
+ASMSRC = $(ALLASMSRC)
+ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(CHIBIOS)/os/license \
- $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/hal/lib/streams $(CHIBIOS)/os/various
+INCDIR = $(ALLINC) $(CHIBIOS)/os/various
#
# Project, sources and paths
diff --git a/testhal/ATSAMA5D2/RTC/main.c b/testhal/ATSAMA5D2/RTC/main.c index 6f0556946..49865e6d3 100644 --- a/testhal/ATSAMA5D2/RTC/main.c +++ b/testhal/ATSAMA5D2/RTC/main.c @@ -77,10 +77,6 @@ int main(void) { */
sdStart(&SD1, &sdcfg);
- /* Redirecting UART1 RX on PD2 and UART1 TX on PD3. */
- palSetGroupMode(PIOD, PAL_PORT_BIT(2) | PAL_PORT_BIT(3), 0U,
- PAL_SAMA_FUNC_PERIPH_A | PAL_MODE_SECURE);
-
chThdCreateStatic(waThread1, sizeof(waThread1), NORMALPRIO , Thread1, NULL);
/*
|