diff options
author | edolomb <none@example.com> | 2018-03-16 15:04:54 +0000 |
---|---|---|
committer | edolomb <none@example.com> | 2018-03-16 15:04:54 +0000 |
commit | ae18581dd903c5b0bf1d07e7465cbebfb14597f8 (patch) | |
tree | 7467cfa82957e1cac59189698abd56ed05624463 /testhal/ATSAMA5D2/SDMMC | |
parent | 8e1851be0ef7d20563085907460f9bb77ed2ebba (diff) | |
download | ChibiOS-ae18581dd903c5b0bf1d07e7465cbebfb14597f8.tar.gz ChibiOS-ae18581dd903c5b0bf1d07e7465cbebfb14597f8.tar.bz2 ChibiOS-ae18581dd903c5b0bf1d07e7465cbebfb14597f8.zip |
- Updated demos
- Minor changes
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@11779 110e8d01-0319-4d1e-a829-52ad28d1bb01
Diffstat (limited to 'testhal/ATSAMA5D2/SDMMC')
-rw-r--r-- | testhal/ATSAMA5D2/SDMMC/Makefile | 44 | ||||
-rw-r--r-- | testhal/ATSAMA5D2/SDMMC/readme.txt | 2 |
2 files changed, 24 insertions, 22 deletions
diff --git a/testhal/ATSAMA5D2/SDMMC/Makefile b/testhal/ATSAMA5D2/SDMMC/Makefile index c9dc8bec4..8bf1beb75 100644 --- a/testhal/ATSAMA5D2/SDMMC/Makefile +++ b/testhal/ATSAMA5D2/SDMMC/Makefile @@ -108,9 +108,14 @@ endif # Define project name here
PROJECT = ch
+BUILDDIR := ./build
+DEPDIR := ./.dep
# Imported source files and paths
CHIBIOS = ../../..
+
+# Licensing files.
+include $(CHIBIOS)/os/license/license.mk
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCAx-TZ/compilers/GCC/mk/startup_sama5d2.mk
# HAL-OSAL files (optional).
@@ -121,31 +126,30 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk # RTOS files (optional).
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCAx-TZ/compilers/GCC/mk/port_generic.mk
+# Other files (optional).
+#include $(CHIBIOS)/test/lib/test.mk
+#include $(CHIBIOS)/test/rt/rt_test.mk
+#include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/various/reledge_bindings/reledge.mk
include $(CHIBIOS)/os/various/fatfs_bindings/fatfs.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
+
# Define linker script file here
#LDSCRIPT= $(STARTUPLD)/SAMA5D2.ld
LDSCRIPT= $(STARTUPLD)/SAMA5D2ddr.ld
+
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(STARTUPSRC) \
- $(KERNSRC) \
- $(PORTSRC) \
- $(OSALSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC) \
- $(TESTSRC) $(STREAMSSRC) \
- main.c fat32test.c reledgetest.c redconf.c $(RELEDGESRC)
-
-CSRC += $(CHIBIOS)/os/various/syscalls.c
-CSRC += $(CHIBIOS)/os/various/fatfs_bindings/fatfs_syscall.c
-CSRC += $(CHIBIOS)/ext/fatfs/src/ff.c
-CSRC += $(CHIBIOS)/ext/fatfs/src/ffunicode.c
+CSRC = $(ALLCSRC) main.c fat32test.c reledgetest.c redconf.c
+
+#CSRC += $(CHIBIOS)/os/various/syscalls.c
+#CSRC += $(CHIBIOS)/os/various/fatfs_bindings/fatfs_syscall.c
+#CSRC += $(CHIBIOS)/ext/fatfs/src/ff.c
+#CSRC += $(CHIBIOS)/ext/fatfs/src/ffunicode.c
+
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(ALLCPPSRC)
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -168,13 +172,11 @@ TCSRC = TCPPSRC =
# List ASM source files here
-ASMSRC =
-ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
+ASMSRC = $(ALLASMSRC)
+ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(CHIBIOS)/os/license \
- $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various $(STREAMSINC) $(FATFSINC) $(RELEDGEINC)
+INCDIR = $(ALLINC) \
+ $(FATFSINC) $(RELEDGEINC)
#
# Project, sources and paths
diff --git a/testhal/ATSAMA5D2/SDMMC/readme.txt b/testhal/ATSAMA5D2/SDMMC/readme.txt index 49423b98c..620f0791b 100644 --- a/testhal/ATSAMA5D2/SDMMC/readme.txt +++ b/testhal/ATSAMA5D2/SDMMC/readme.txt @@ -4,7 +4,7 @@ ** TARGET **
-The demo targets a generic ARM Cortex-A5 device without HAL support.
+The demo runs on an SAMA5D2-XPLAINED board.
** The Demo **
Testing FF and Reliance Edge Libraries
|