diff options
author | Fabio Utzig <utzig@utzig.org> | 2015-09-14 21:31:52 +0000 |
---|---|---|
committer | Fabio Utzig <utzig@utzig.org> | 2015-09-14 21:31:52 +0000 |
commit | 2130f39ba3f3ad8893cd149a600d5fd5477994a5 (patch) | |
tree | d20df969fdc5b3aa25a5b9bed7a91376e78d5c9e /testhal/KINETIS | |
parent | 8a9e2826eeff5d92db01066c451ffd96a4d0afe1 (diff) | |
download | ChibiOS-2130f39ba3f3ad8893cd149a600d5fd5477994a5.tar.gz ChibiOS-2130f39ba3f3ad8893cd149a600d5fd5477994a5.tar.bz2 ChibiOS-2130f39ba3f3ad8893cd149a600d5fd5477994a5.zip |
[KINETIS] Fixed ADC hal test build + disable unused serial
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@8297 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'testhal/KINETIS')
-rw-r--r-- | testhal/KINETIS/ADC/Makefile | 20 | ||||
-rw-r--r-- | testhal/KINETIS/ADC/halconf.h | 2 | ||||
-rw-r--r-- | testhal/KINETIS/ADC/mcuconf.h | 2 |
3 files changed, 12 insertions, 12 deletions
diff --git a/testhal/KINETIS/ADC/Makefile b/testhal/KINETIS/ADC/Makefile index 23716dd01..104981773 100644 --- a/testhal/KINETIS/ADC/Makefile +++ b/testhal/KINETIS/ADC/Makefile @@ -82,24 +82,24 @@ PROJECT = ch # Imported source files and paths
CHIBIOS = ../../..
+include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_kl2x.mk
include $(CHIBIOS)/os/hal/hal.mk
-include $(CHIBIOS)/os/hal/boards/FREESCALE_FREEDOM_KL25Z/board.mk
include $(CHIBIOS)/os/hal/ports/KINETIS/KL2x/platform.mk
+include $(CHIBIOS)/os/hal/boards/FREESCALE_FREEDOM_KL25Z/board.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
-include $(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/mk/port_kl2x.mk
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/mk/port_v6m.mk
# Define linker script file here
-LDSCRIPT= $(PORTLD)/KL25Z128.ld
+LDSCRIPT= $(STARTUPLD)/KL25Z128.ld
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(PORTSRC) \
+CSRC = $(STARTUPSRC) \
$(KERNSRC) \
- $(TESTSRC) \
- $(HALSRC) \
+ $(PORTSRC) \
$(OSALSRC) \
+ $(HALSRC) \
$(PLATFORMSRC) \
$(BOARDSRC) \
main.c
@@ -129,10 +129,10 @@ TCSRC = TCPPSRC =
# List ASM source files here
-ASMSRC = $(PORTASM)
+ASMSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
-INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \
- $(HALINC) $(OSALINC) $(PLATFORMINC) $(BOARDINC) \
+INCDIR = $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
+ $(HALINC) $(PLATFORMINC) $(BOARDINC) \
$(CHIBIOS)/os/various
#
diff --git a/testhal/KINETIS/ADC/halconf.h b/testhal/KINETIS/ADC/halconf.h index 29155d16b..d3f8bfef7 100644 --- a/testhal/KINETIS/ADC/halconf.h +++ b/testhal/KINETIS/ADC/halconf.h @@ -132,7 +132,7 @@ * @brief Enables the SERIAL subsystem.
*/
#if !defined(HAL_USE_SERIAL) || defined(__DOXYGEN__)
-#define HAL_USE_SERIAL TRUE
+#define HAL_USE_SERIAL FALSE
#endif
/**
diff --git a/testhal/KINETIS/ADC/mcuconf.h b/testhal/KINETIS/ADC/mcuconf.h index 3dafa8585..03a7de550 100644 --- a/testhal/KINETIS/ADC/mcuconf.h +++ b/testhal/KINETIS/ADC/mcuconf.h @@ -71,7 +71,7 @@ /*
* SERIAL driver system settings.
*/
-#define KINETIS_SERIAL_USE_UART0 TRUE
+#define KINETIS_SERIAL_USE_UART0 FALSE
/*
* ADC driver system settings.
|