aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/I2C
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-11-04 16:03:57 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-11-04 16:03:57 +0000
commite6fbbc4da8ddf97e053651ad3d38802429562a23 (patch)
tree4e2f29b4d9d9b034c306cbbc906ddf2f07f2d59e /testhal/STM32/STM32F4xx/I2C
parentb8352d5f4b945b307d5850b3bb2259e9ea3c75a8 (diff)
downloadChibiOS-e6fbbc4da8ddf97e053651ad3d38802429562a23.tar.gz
ChibiOS-e6fbbc4da8ddf97e053651ad3d38802429562a23.tar.bz2
ChibiOS-e6fbbc4da8ddf97e053651ad3d38802429562a23.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10939 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'testhal/STM32/STM32F4xx/I2C')
-rw-r--r--testhal/STM32/STM32F4xx/I2C/Makefile4
-rw-r--r--testhal/STM32/STM32F4xx/I2C/main.c2
2 files changed, 3 insertions, 3 deletions
diff --git a/testhal/STM32/STM32F4xx/I2C/Makefile b/testhal/STM32/STM32F4xx/I2C/Makefile
index e49c5aac7..b4f78f873 100644
--- a/testhal/STM32/STM32F4xx/I2C/Makefile
+++ b/testhal/STM32/STM32F4xx/I2C/Makefile
@@ -99,8 +99,8 @@ include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
#include $(CHIBIOS)/test/lib/test.mk
-include $(CHIBIOS)/test/rt/rt_test.mk
-include $(CHIBIOS)/test/oslib/oslib_test.mk
+#include $(CHIBIOS)/test/rt/rt_test.mk
+#include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F407xG.ld
diff --git a/testhal/STM32/STM32F4xx/I2C/main.c b/testhal/STM32/STM32F4xx/I2C/main.c
index 7aae38784..46afa4ecf 100644
--- a/testhal/STM32/STM32F4xx/I2C/main.c
+++ b/testhal/STM32/STM32F4xx/I2C/main.c
@@ -110,7 +110,7 @@ static const I2CConfig i2cfg2 = {
*/
int main(void) {
msg_t status = MSG_OK;
- systime_t tmo = MS2ST(4);
+ sysinterval_t tmo = TIME_MS2I(4);
/*
* System initializations.