diff options
author | Rocco Marco Guglielmi <roccomarco.guglielmi@live.com> | 2016-08-31 19:55:08 +0000 |
---|---|---|
committer | Rocco Marco Guglielmi <roccomarco.guglielmi@live.com> | 2016-08-31 19:55:08 +0000 |
commit | 11eb96e9b8121ccdab2b7391ec4eb18051f3345b (patch) | |
tree | 03826aed997e334b41a7d758ff297b1e3595ea0d /testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile | |
parent | eb63492a0c965f72b965dd155617d2598a3b83ca (diff) | |
download | ChibiOS-11eb96e9b8121ccdab2b7391ec4eb18051f3345b.tar.gz ChibiOS-11eb96e9b8121ccdab2b7391ec4eb18051f3345b.tar.bz2 ChibiOS-11eb96e9b8121ccdab2b7391ec4eb18051f3345b.zip |
Updated STM32L4xx-I2C-LSM6DS0 demo and added a new demo for STM32 Nucleo-64 F401RE
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@9759 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile')
-rw-r--r-- | testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile | 12 |
1 files changed, 8 insertions, 4 deletions
diff --git a/testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile b/testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile index 641eb15d0..bdfbb5c70 100644 --- a/testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile +++ b/testhal/STM32/STM32L4xx/I2C-LSM6DS0/Makefile @@ -5,7 +5,7 @@ # Compiler options here.
ifeq ($(USE_OPT),)
- USE_OPT = -O2 -ggdb -fomit-frame-pointer -falign-functions=16
+ USE_OPT = -O0 -ggdb -fomit-frame-pointer -falign-functions=16
endif
# C specific options here (added to USE_OPT).
@@ -100,6 +100,7 @@ include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk # Other files (optional).
include $(CHIBIOS)/os/ex/ST/lsm6ds0.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
+include $(CHIBIOS)/os/various/shell/shell.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32L476xG.ld
@@ -115,6 +116,7 @@ CSRC = $(STARTUPSRC) \ $(BOARDSRC) \
$(LSM6DS0SRC) \
$(STREAMSSRC) \
+ $(SHELLSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
@@ -148,7 +150,7 @@ ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM) INCDIR = $(CHIBIOS)/os/license \
$(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(LSM6DS0INC) \
- $(STREAMSINC) $(CHIBIOS)/os/various
+ $(STREAMSINC) $(SHELLINC)
#
# Project, sources and paths
@@ -198,8 +200,10 @@ CPPWARN = -Wall -Wextra -Wundef #
# List all user C define here, like -D_DEBUG=1
-UDEFS = -DCHPRINTF_USE_FLOAT=1
-
+UDEFS = -DCHPRINTF_USE_FLOAT=1 -DSHELL_CMD_TEST_ENABLED=0 \
+ -DLSM6DS0_USE_ADVANCED=0 -DLSM6DS0_GYRO_USE_ADVANCED=0 \
+ -DLSM6DS0_ACC_USE_ADVANCED=0
+
# Define ASM defines here
UADEFS =
|