aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--os/hal/lib/streams/chprintf.c3
-rw-r--r--readme.txt2
2 files changed, 1 insertions, 4 deletions
diff --git a/os/hal/lib/streams/chprintf.c b/os/hal/lib/streams/chprintf.c
index 737d01341..5875d3e8a 100644
--- a/os/hal/lib/streams/chprintf.c
+++ b/os/hal/lib/streams/chprintf.c
@@ -163,9 +163,8 @@ int chvprintf(BaseSequentialStream *chp, const char *fmt, va_list ap) {
break;
width = width * 10 + c;
}
- precision = 6;
+ precision = 0;
if (c == '.') {
- precision = 0;
while (TRUE) {
c = *fmt++;
if (c >= '0' && c <= '9')
diff --git a/readme.txt b/readme.txt
index fa1a6cf1a..f1dbbe31a 100644
--- a/readme.txt
+++ b/readme.txt
@@ -168,8 +168,6 @@
Updated the various platform.mk implementing "smart build" mode.
- LIB: Fixed inner semaphore not updated in chGuardedPoolAllocI() function
(bug #911).
-- HAL: Fixed chprintf float support for 0 precision (bug #910)(backported to
- 17.6.4 and 16.1.10).
- RT: Fixed compile error with assertions enabled and dynamic extensions
disabled (bug #909)(backported to 17.6.4).
- HAL: Fixed compile error HAL UART without WAIT (bug #908)(backported to