aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testhal/ATSAMA5D2/SPI/Makefile4
-rw-r--r--testhal/ATSAMA5D2/SPI/main.c2
2 files changed, 3 insertions, 3 deletions
diff --git a/testhal/ATSAMA5D2/SPI/Makefile b/testhal/ATSAMA5D2/SPI/Makefile
index 8b67c8404..0e477d2d4 100644
--- a/testhal/ATSAMA5D2/SPI/Makefile
+++ b/testhal/ATSAMA5D2/SPI/Makefile
@@ -225,10 +225,10 @@ CPPWARN = -Wall -Wextra -Wundef
#
# List all user C define here, like -D_DEBUG=1
-UDEFS = -DCH_CFG_USE_MMU
+UDEFS =
# Define ASM defines here
-UADEFS = -DCH_CFG_USE_MMU
+UADEFS =
# List all user directories here
UINCDIR =
diff --git a/testhal/ATSAMA5D2/SPI/main.c b/testhal/ATSAMA5D2/SPI/main.c
index 5807109fb..33e590bc4 100644
--- a/testhal/ATSAMA5D2/SPI/main.c
+++ b/testhal/ATSAMA5D2/SPI/main.c
@@ -57,7 +57,7 @@ static void rxend(SPIDriver *spip) {
static const SPIConfig mst_spicfg = {
rxend, /* callback if present */
0, /* cs pad number */
- SPI_MR_MODFDIS | SPI_MR_MSTR | SPI_MR_LLB, /* mr register */
+ SPI_MR_MODFDIS | SPI_MR_LLB, /* mr register */
SPI_CSR_SCBR(1) /* csr */
};