aboutsummaryrefslogtreecommitdiffstats
path: root/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB
diff options
context:
space:
mode:
Diffstat (limited to 'demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB')
-rw-r--r--demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/Makefile4
-rw-r--r--demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/main.c1
2 files changed, 3 insertions, 2 deletions
diff --git a/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/Makefile b/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/Makefile
index 85a28d756..88486a510 100644
--- a/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/Makefile
+++ b/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/Makefile
@@ -98,7 +98,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk
include $(CHIBIOS)/os/various/fatfs_bindings/fatfs.mk
diff --git a/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/main.c b/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/main.c
index 7ae75aa63..ec91f939a 100644
--- a/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/main.c
+++ b/demos/STM32/RT-STM32F103-STM3210E_EVAL-FATFS-USB/main.c
@@ -19,7 +19,6 @@
#include "ch.h"
#include "hal.h"
-#include "rt_test_root.h"
#include "chprintf.h"
#include "shell.h"