diff options
Diffstat (limited to 'demos/STM32/RT-STM32F746G-DISCOVERY')
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/Makefile | 14 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/cfg/chconf.h (renamed from demos/STM32/RT-STM32F746G-DISCOVERY/chconf.h) | 0 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/cfg/halconf.h (renamed from demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h) | 0 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/cfg/mcuconf.h (renamed from demos/STM32/RT-STM32F746G-DISCOVERY/mcuconf.h) | 0 |
4 files changed, 7 insertions, 7 deletions
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile index 8c571546d..4c8954433 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile @@ -18,7 +18,7 @@ ifeq ($(USE_CPPOPT),) USE_CPPOPT = -fno-rtti
endif
-# Enable this if you want the linker to remove unused code and data
+# Enable this if you want the linker to remove unused code and data.
ifeq ($(USE_LINK_GC),)
USE_LINK_GC = yes
endif
@@ -28,7 +28,7 @@ ifeq ($(USE_LDOPT),) USE_LDOPT =
endif
-# Enable this if you want link time optimizations (LTO)
+# Enable this if you want link time optimizations (LTO).
ifeq ($(USE_LTO),)
USE_LTO = yes
endif
@@ -91,8 +91,8 @@ endif PROJECT = ch
# Imported source files and paths
-CHIBIOS := ../../..
-CONFDIR := .
+CHIBIOS = ../../..
+CONFDIR := ./cfg
BUILDDIR := ./build
DEPDIR := ./.dep
@@ -148,11 +148,11 @@ TCSRC = # option that results in lower performance and larger code size.
TCPPSRC =
-# List ASM source files here
-ASMSRC = $(ALLASMSRC) $(ALLASMSRC)
+# List ASM source files here.
+ASMSRC = $(ALLASMSRC)
ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(ALLINC) $(TESTINC)
+INCDIR = $(CONFDIR) $(ALLINC) $(TESTINC)
#
# Project, sources and paths
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/chconf.h b/demos/STM32/RT-STM32F746G-DISCOVERY/cfg/chconf.h index 665a147d4..665a147d4 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/chconf.h +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/cfg/chconf.h diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h b/demos/STM32/RT-STM32F746G-DISCOVERY/cfg/halconf.h index 6e5569097..6e5569097 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/cfg/halconf.h diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/mcuconf.h b/demos/STM32/RT-STM32F746G-DISCOVERY/cfg/mcuconf.h index 2d5eea42c..2d5eea42c 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/mcuconf.h +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/cfg/mcuconf.h |