aboutsummaryrefslogtreecommitdiffstats
path: root/demos/STM32/RT-STM32F746G-DISCOVERY
diff options
context:
space:
mode:
Diffstat (limited to 'demos/STM32/RT-STM32F746G-DISCOVERY')
-rw-r--r--demos/STM32/RT-STM32F746G-DISCOVERY/Makefile2
-rw-r--r--demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h4
2 files changed, 3 insertions, 3 deletions
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile
index 4064da39b..b23e1c7d6 100644
--- a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile
+++ b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile
@@ -5,7 +5,7 @@
# Compiler options here.
ifeq ($(USE_OPT),)
- USE_OPT = -O0 -ggdb -fomit-frame-pointer -falign-functions=16
+ USE_OPT = -O2 -ggdb -fomit-frame-pointer -falign-functions=16
endif
# C specific options here (added to USE_OPT).
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h b/demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h
index a551b35b6..d7793e22c 100644
--- a/demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h
+++ b/demos/STM32/RT-STM32F746G-DISCOVERY/halconf.h
@@ -55,7 +55,7 @@
* @brief Enables the cryptographic subsystem.
*/
#if !defined(HAL_USE_CRY) || defined(__DOXYGEN__)
-#define HAL_USE_CRY TRUE
+#define HAL_USE_CRY FALSE
#endif
/**
@@ -227,7 +227,7 @@
* @note Fall-back implementations may not be present for all algorithms.
*/
#if !defined(HAL_CRY_USE_FALLBACK) || defined(__DOXYGEN__)
-#define HAL_CRY_USE_FALLBACK TRUE
+#define HAL_CRY_USE_FALLBACK FALSE
#endif
/**