diff options
Diffstat (limited to 'os/common/startup/SIMIA32/compilers/GCC/rules.mk')
-rw-r--r-- | os/common/startup/SIMIA32/compilers/GCC/rules.mk | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/os/common/startup/SIMIA32/compilers/GCC/rules.mk b/os/common/startup/SIMIA32/compilers/GCC/rules.mk index 600f8d5e9..1dfea462e 100644 --- a/os/common/startup/SIMIA32/compilers/GCC/rules.mk +++ b/os/common/startup/SIMIA32/compilers/GCC/rules.mk @@ -169,7 +169,8 @@ $(BUILDDIR)/lib$(PROJECT).a: $(OBJS) clean: CLEAN_RULE_HOOK
@echo Cleaning
- -rm -fR $(DEPDIR) $(BUILDDIR)
+ -rm -fR $(DEPDIR)/* $(BUILDDIR)/* 2>/dev/null
+ -rmdir -p --ignore-fail-on-non-empty $(subst ./,,$(DEPDIR)) $(subst ./,,$(BUILDDIR)) 2>/dev/null
@echo
@echo Done
@@ -182,6 +183,6 @@ gcov: #
# Include the dependency files, should be the last of the makefile
#
--include $(shell mkdir $(DEPDIR) 2>/dev/null) $(wildcard $(DEPDIR)/*)
+-include $(shell mkdir -p $(DEPDIR) 2>/dev/null) $(wildcard $(DEPDIR)/*)
# *** EOF ***
|