aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/platforms/STM32L1xx/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/platforms/STM32L1xx/platform.mk')
-rw-r--r--os/hal/platforms/STM32L1xx/platform.mk18
1 files changed, 15 insertions, 3 deletions
diff --git a/os/hal/platforms/STM32L1xx/platform.mk b/os/hal/platforms/STM32L1xx/platform.mk
index f870811fc..348722671 100644
--- a/os/hal/platforms/STM32L1xx/platform.mk
+++ b/os/hal/platforms/STM32L1xx/platform.mk
@@ -1,6 +1,18 @@
-# List of all the STM32 platform files.
+# List of all the STM32L1xx platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/platforms/STM32L1xx/hal_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32L1xx/stm32_dma.c
+ ${CHIBIOS}/os/hal/platforms/STM32/gpt_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/icu_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/pwm_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/serial_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/GPIOv2/pal_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/spi_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/uart_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/stm32_dma.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/USBv1/usb_lld.c
# Required include directories
-PLATFORMINC = ${CHIBIOS}/os/hal/platforms/STM32L1xx
+PLATFORMINC = ${CHIBIOS}/os/hal/platforms/STM32L1xx \
+ ${CHIBIOS}/os/hal/platforms/STM32 \
+ ${CHIBIOS}/os/hal/platforms/STM32/GPIOv2 \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1 \
+ ${CHIBIOS}/os/hal/platforms/STM32/USBv1