diff options
Diffstat (limited to 'os/hal/templates/platform.mk')
-rw-r--r-- | os/hal/templates/platform.mk | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/os/hal/templates/platform.mk b/os/hal/templates/platform.mk index 13ea8a7c6..533c654c3 100644 --- a/os/hal/templates/platform.mk +++ b/os/hal/templates/platform.mk @@ -61,6 +61,9 @@ endif ifneq ($(findstring HAL_USE_SPI TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_spi_lld.c
endif
+ifneq ($(findstring HAL_USE_TRNG TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_trng_lld.c
+endif
ifneq ($(findstring HAL_USE_UART TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS}/os/hal/templates/hal_uart_lld.c
endif
@@ -90,6 +93,7 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/templates/hal_lld.c \ ${CHIBIOS}/os/hal/templates/hal_serial_lld.c \
${CHIBIOS}/os/hal/templates/hal_spi_lld.c \
${CHIBIOS}/os/hal/templates/hal_st_lld.c \
+ ${CHIBIOS}/os/hal/templates/hal_trng_lld.c \
${CHIBIOS}/os/hal/templates/hal_uart_lld.c \
${CHIBIOS}/os/hal/templates/hal_usb_lld.c \
${CHIBIOS}/os/hal/templates/hal_wdg_lld.c
|