aboutsummaryrefslogtreecommitdiffstats
path: root/test
diff options
context:
space:
mode:
Diffstat (limited to 'test')
-rw-r--r--test/hal/testbuild/Makefile4
-rw-r--r--test/hal/testbuild/board.h40
-rw-r--r--test/hal/testbuild/main.c2
-rw-r--r--test/rt/testbuild/Makefile2
-rw-r--r--test/rt/testbuild/chconf.h2
-rw-r--r--test/rt/testbuild/go.sh4
6 files changed, 8 insertions, 46 deletions
diff --git a/test/hal/testbuild/Makefile b/test/hal/testbuild/Makefile
index 6cb730058..165ff35cd 100644
--- a/test/hal/testbuild/Makefile
+++ b/test/hal/testbuild/Makefile
@@ -91,8 +91,8 @@ CHIBIOS = ../../..
include $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
# HAL-OSAL files (optional).
include $(CHIBIOS)/os/hal/hal.mk
-include $(CHIBIOS)/os/hal/templates/platform.mk
-#include $(CHIBIOS)/os/hal/boards/xxxxxxx/board.mk
+include $(CHIBIOS)/os/hal/ports/common/platform.mk
+include $(CHIBIOS)/os/hal/templates/board/board.mk
include $(CHIBIOS)/os/hal/templates/osal/osal.mk
# RTOS files (optional).
#include $(CHIBIOS)/os/rt/rt.mk
diff --git a/test/hal/testbuild/board.h b/test/hal/testbuild/board.h
deleted file mode 100644
index 408cbb918..000000000
--- a/test/hal/testbuild/board.h
+++ /dev/null
@@ -1,40 +0,0 @@
-/*
- ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
-*/
-
-#ifndef BOARD_H
-#define BOARD_H
-
-/*
- * Setup for a generic board.
- */
-
-/*
- * Board identifier.
- */
-#define BOARD_GENERIC
-#define BOARD_NAME "Generic Board"
-
-#if !defined(_FROM_ASM_)
-#ifdef __cplusplus
-extern "C" {
-#endif
- void boardInit(void);
-#ifdef __cplusplus
-}
-#endif
-#endif /* _FROM_ASM_ */
-
-#endif /* BOARD_H */
diff --git a/test/hal/testbuild/main.c b/test/hal/testbuild/main.c
index 6d9c03d46..505ef03bd 100644
--- a/test/hal/testbuild/main.c
+++ b/test/hal/testbuild/main.c
@@ -24,5 +24,7 @@ int main(int argc, char *argv[]) {
(void)argc;
(void)argv;
+ halInit();
+
return 0;
}
diff --git a/test/rt/testbuild/Makefile b/test/rt/testbuild/Makefile
index cc4d2bfb7..b33a8dc9f 100644
--- a/test/rt/testbuild/Makefile
+++ b/test/rt/testbuild/Makefile
@@ -41,7 +41,7 @@ endif
# If enabled, this option makes the build process faster by not compiling
# modules not used in the current configuration.
ifeq ($(USE_SMART_BUILD),)
- USE_SMART_BUILD = yes
+ USE_SMART_BUILD = no
endif
#
diff --git a/test/rt/testbuild/chconf.h b/test/rt/testbuild/chconf.h
index 091c93e7c..eb6a6cce4 100644
--- a/test/rt/testbuild/chconf.h
+++ b/test/rt/testbuild/chconf.h
@@ -463,7 +463,7 @@
* tickless mode.
*/
#if !defined(CH_DBG_THREADS_PROFILING) || defined(__DOXIGEN__)
-#define CH_DBG_THREADS_PROFILING FALSE
+#define CH_DBG_THREADS_PROFILING TRUE
#endif
/** @} */
diff --git a/test/rt/testbuild/go.sh b/test/rt/testbuild/go.sh
index 937e1ebde..9915882ae 100644
--- a/test/rt/testbuild/go.sh
+++ b/test/rt/testbuild/go.sh
@@ -112,11 +112,11 @@ test cfg22 "-DCH_DBG_STATISTICS=TRUE"
test cfg23 "-DCH_DBG_SYSTEM_STATE_CHECK=TRUE"
test cfg24 "-DCH_DBG_ENABLE_CHECKS=TRUE"
test cfg25 "-DCH_DBG_ENABLE_ASSERTS=TRUE"
-test cfg26 "-DCH_DBG_ENABLE_TRACE=TRUE"
+test cfg26 "-DCH_DBG_TRACE_MASK=CH_DBG_TRACE_MASK_ALL"
#test cfg27 "-DCH_DBG_ENABLE_STACK_CHECK=TRUE"
test cfg28 "-DCH_DBG_FILL_THREADS=TRUE"
test cfg29 "-DCH_DBG_THREADS_PROFILING=FALSE"
-test cfg30 "-DCH_DBG_SYSTEM_STATE_CHECK=TRUE -DCH_DBG_ENABLE_CHECKS=TRUE -DCH_DBG_ENABLE_ASSERTS=TRUE -DCH_DBG_ENABLE_TRACE=TRUE -DCH_DBG_FILL_THREADS=TRUE"
+test cfg30 "-DCH_DBG_SYSTEM_STATE_CHECK=TRUE -DCH_DBG_ENABLE_CHECKS=TRUE -DCH_DBG_ENABLE_ASSERTS=TRUE -DCH_DBG_TRACE_MASK=CH_DBG_TRACE_MASK_ALL -DCH_DBG_FILL_THREADS=TRUE"
rm *log.txt 2> /dev/null
echo