diff options
Diffstat (limited to 'testhal/STM32/STM32F7xx/USB_CDC')
-rw-r--r-- | testhal/STM32/STM32F7xx/USB_CDC/Makefile | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/testhal/STM32/STM32F7xx/USB_CDC/Makefile b/testhal/STM32/STM32F7xx/USB_CDC/Makefile index 926096a14..8a5a9a774 100644 --- a/testhal/STM32/STM32F7xx/USB_CDC/Makefile +++ b/testhal/STM32/STM32F7xx/USB_CDC/Makefile @@ -74,6 +74,11 @@ ifeq ($(USE_FPU),) USE_FPU = no
endif
+# FPU-related options.
+ifeq ($(USE_FPU_OPT),)
+ USE_FPU_OPT = -mfloat-abi=$(USE_FPU) -mfpu=fpv5-sp-d16 -fsingle-precision-constant
+endif
+
#
# Architecture or project specific options
##############################################################################
@@ -160,7 +165,7 @@ INCDIR = $(CHIBIOS)/os/license \ # Compiler settings
#
-MCU = cortex-m4
+MCU = cortex-m7
#TRGT = arm-elf-
TRGT = arm-none-eabi-
|