aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFred Sundvik <fsundvik@gmail.com>2016-05-17 09:45:05 +0300
committerFred Sundvik <fsundvik@gmail.com>2016-05-17 09:45:05 +0300
commit4e89732617454a600189242d417f5e2ba0855683 (patch)
tree4d00e56c7e8962c43e9ae5b519144d588f93a8bc
parentd79e94adb1182ae867df0cc7621ef3d44d213bbc (diff)
downloadfirmware-4e89732617454a600189242d417f5e2ba0855683.tar.gz
firmware-4e89732617454a600189242d417f5e2ba0855683.tar.bz2
firmware-4e89732617454a600189242d417f5e2ba0855683.zip
Enable and fix compilation of more files
-rw-r--r--led_test.c24
-rw-r--r--visualizer.mk6
2 files changed, 13 insertions, 17 deletions
diff --git a/led_test.c b/led_test.c
index d358ef81e..6d3f3b2ed 100644
--- a/led_test.c
+++ b/led_test.c
@@ -29,20 +29,20 @@ keyframe_animation_t led_test_animation = {
.num_frames = 14,
.loop = true,
.frame_lengths = {
- MS2ST(1000), // fade in
- MS2ST(1000), // no op (leds on)
- MS2ST(1000), // fade out
- MS2ST(1000), // crossfade
- MS2ST(3000), // left to rigt (outside in)
- MS2ST(1000), // crossfade
- MS2ST(3000), // top_to_bottom
+ gfxMillisecondsToTicks(1000), // fade in
+ gfxMillisecondsToTicks(1000), // no op (leds on)
+ gfxMillisecondsToTicks(1000), // fade out
+ gfxMillisecondsToTicks(1000), // crossfade
+ gfxMillisecondsToTicks(3000), // left to rigt (outside in)
+ gfxMillisecondsToTicks(1000), // crossfade
+ gfxMillisecondsToTicks(3000), // top_to_bottom
0, // mirror leds
- MS2ST(1000), // crossfade
- MS2ST(3000), // left_to_right (mirrored, so inside out)
- MS2ST(1000), // crossfade
- MS2ST(3000), // top_to_bottom
+ gfxMillisecondsToTicks(1000), // crossfade
+ gfxMillisecondsToTicks(3000), // left_to_right (mirrored, so inside out)
+ gfxMillisecondsToTicks(1000), // crossfade
+ gfxMillisecondsToTicks(3000), // top_to_bottom
0, // normal leds
- MS2ST(1000), // crossfade
+ gfxMillisecondsToTicks(1000), // crossfade
},
.frame_functions = {
diff --git a/visualizer.mk b/visualizer.mk
index 678829329..56525ffd9 100644
--- a/visualizer.mk
+++ b/visualizer.mk
@@ -31,17 +31,15 @@ USE_UGFX = yes
endif
ifdef LCD_BACKLIGHT_ENABLE
-ifndef EMULATOR
SRC += $(VISUALIZER_DIR)/lcd_backlight.c
+ifndef EMULATOR
SRC += lcd_backlight_hal.c
endif
UDEFS += -DLCD_BACKLIGHT_ENABLE
endif
ifdef LED_ENABLE
-ifndef EMULATOR
SRC += $(VISUALIZER_DIR)/led_test.c
-endif
UDEFS += -DLED_ENABLE
USE_UGFX = yes
endif
@@ -54,10 +52,8 @@ ULIBS += $(patsubst %,-l%,$(patsubst -l%,%,$(GFXLIBS)))
endif
ifndef VISUALIZER_USER
-ifndef EMULATOR
VISUALIZER_USER = visualizer_user.c
endif
-endif
SRC += $(VISUALIZER_USER)
ifdef EMULATOR