aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2020-09-23 18:52:04 -0700
committerGitHub <noreply@github.com>2020-09-23 18:52:04 -0700
commit940280c43594833e2208d8514452b8ab88c14a9c (patch)
treec1129842f7fae7acbb77fb77716c7fce0db5d25a
parent940c294d26dfe5ab51b094db4f76cc819cdb18f5 (diff)
downloadfirmware-940280c43594833e2208d8514452b8ab88c14a9c.tar.gz
firmware-940280c43594833e2208d8514452b8ab88c14a9c.tar.bz2
firmware-940280c43594833e2208d8514452b8ab88c14a9c.zip
VIA Support for flehrad Big Switch (#10325)
* add VIA keymap * Update keyboards/flehrad/bigswitch/keymaps/via/keymap.c
-rw-r--r--keyboards/flehrad/bigswitch/keymaps/via/keymap.c29
-rw-r--r--keyboards/flehrad/bigswitch/keymaps/via/rules.mk2
2 files changed, 31 insertions, 0 deletions
diff --git a/keyboards/flehrad/bigswitch/keymaps/via/keymap.c b/keyboards/flehrad/bigswitch/keymaps/via/keymap.c
new file mode 100644
index 000000000..f253f4b12
--- /dev/null
+++ b/keyboards/flehrad/bigswitch/keymaps/via/keymap.c
@@ -0,0 +1,29 @@
+/*
+Copyright 2020 MechMerlin
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+
+ [0] = LAYOUT(KC_TRNS),
+
+ [1] = LAYOUT(KC_TRNS),
+
+ [2] = LAYOUT(KC_TRNS),
+
+ [3] = LAYOUT(KC_TRNS)
+};
diff --git a/keyboards/flehrad/bigswitch/keymaps/via/rules.mk b/keyboards/flehrad/bigswitch/keymaps/via/rules.mk
new file mode 100644
index 000000000..36b7ba9cb
--- /dev/null
+++ b/keyboards/flehrad/bigswitch/keymaps/via/rules.mk
@@ -0,0 +1,2 @@
+VIA_ENABLE = yes
+LTO_ENABLE = yes