aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJack Humbert <jack.humb@gmail.com>2016-07-06 09:48:58 -0400
committerGitHub <noreply@github.com>2016-07-06 09:48:58 -0400
commit19f480992c015aec0a15dca43e740bad8b7834e6 (patch)
tree2d1470d076017af6d089a00f4bb317abdb331346 /Makefile
parentc6d671e54c249497b5c01ad9badaa50425f394f9 (diff)
parente5726b017a9de2922ea923818c6e215600f68a85 (diff)
downloadfirmware-19f480992c015aec0a15dca43e740bad8b7834e6.tar.gz
firmware-19f480992c015aec0a15dca43e740bad8b7834e6.tar.bz2
firmware-19f480992c015aec0a15dca43e740bad8b7834e6.zip
Merge pull request #487 from fredizzimo/serial_link_ergodox
Integrate serial link support for ChibiOS and Infinity Ergodox
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 25 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c285dabad..7c00ce2cc 100644
--- a/Makefile
+++ b/Makefile
@@ -59,6 +59,12 @@ ifndef KEYBOARD
KEYBOARD=planck
endif
+MASTER ?= left
+ifdef master
+ MASTER = $(master)
+endif
+
+
# converts things to keyboards/subproject
ifneq (,$(findstring /,$(KEYBOARD)))
TEMP:=$(KEYBOARD)
@@ -198,10 +204,28 @@ ifeq ($(strip $(RGBLIGHT_ENABLE)), yes)
endif
ifeq ($(strip $(TAP_DANCE_ENABLE)), yes)
- OPT_DEFS += -DTAP_DANCE_ENABLE
+ OPT_DEFS += -DTAP_DANCE_ENABLE
SRC += $(QUANTUM_DIR)/process_keycode/process_tap_dance.c
endif
+ifeq ($(strip $(SERIAL_LINK_ENABLE)), yes)
+ SERIAL_DIR = $(QUANTUM_DIR)/serial_link
+ SERIAL_PATH = $(QUANTUM_PATH)/serial_link
+ SERIAL_SRC = $(wildcard $(SERIAL_PATH)/protocol/*.c)
+ SERIAL_SRC += $(wildcard $(SERIAL_PATH)/system/*.c)
+ SRC += $(patsubst $(QUANTUM_PATH)/%,%,$(SERIAL_SRC))
+ OPT_DEFS += -DSERIAL_LINK_ENABLE
+ VAPTH += $(SERIAL_PATH)
+endif
+
+ifeq ($(MASTER),right)
+ OPT_DEFS += -DMASTER_IS_ON_RIGHT
+else
+ ifneq ($(MASTER),left)
+$(error MASTER does not have a valid value(left/right))
+ endif
+endif
+
# Optimize size but this may cause error "relocation truncated to fit"
#EXTRALDFLAGS = -Wl,--relax