diff options
author | Christopher Browne <cbbrowne@acm.org> | 2016-06-16 17:16:51 -0400 |
---|---|---|
committer | Jack Humbert <jack.humb@gmail.com> | 2016-06-16 17:16:51 -0400 |
commit | 2cf26915e3ed737ae83cf7b54f7e84fc2f0d3b40 (patch) | |
tree | ae497d0e544bd9d02ecc6b2271c36e578aec091e /Makefile | |
parent | 91b469d88fc530412bdd3c604374542898614895 (diff) | |
download | firmware-2cf26915e3ed737ae83cf7b54f7e84fc2f0d3b40.tar.gz firmware-2cf26915e3ed737ae83cf7b54f7e84fc2f0d3b40.tar.bz2 firmware-2cf26915e3ed737ae83cf7b54f7e84fc2f0d3b40.zip |
Sample of using build info to generate keystrokes (#412)
* More documentation
* Saving crontab for user on host
* Restructuring in keeping with recent changes to conventions
* Simplify submitting my fave cbbrowne keystroke by using SEND_STRING()
* Local change, not apropos to have in this repo
* Simplify logic; no need to return so much
* Add in a version key
* Add docs
* Split build date into a separate DEFINE
* Ensure there is a value even if not working within a git repo
* Should not include the compiled code in the repo
* compiled.hex files should not be included in the repo; they represent generated compiled code
* Fix spelling in comment
* Remove more generated files
* Add rule to ignore contents of .build directories; their contents are generated
* Revert removals of compiled files
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -114,7 +114,7 @@ include $(TMK_PATH)/protocol/lufa.mk include $(TMK_PATH)/common.mk include $(TMK_PATH)/rules.mk -GIT_VERSION := $(shell git describe --abbrev=6 --dirty --always --tags 2>/dev/null || date +"%Y-%m-%d") - +GIT_VERSION := $(shell git describe --abbrev=6 --dirty --always --tags 2>/dev/null || date +"%Y-%m-%d-%H:%M:%S") +BUILD_DATE := $(shell date +"%Y-%m-%d-%H:%M:%S") OPT_DEFS += -DQMK_KEYBOARD=\"$(KEYBOARD)\" -DQMK_KEYMAP=\"$(KEYMAP)\" -OPT_DEFS += -DQMK_VERSION=\"$(GIT_VERSION)\" +OPT_DEFS += -DQMK_VERSION=\"$(GIT_VERSION)\" -DQMK_BUILDDATE=\"$(BUILD_DATE)\" |