aboutsummaryrefslogtreecommitdiffstats
path: root/adb_usb
diff options
context:
space:
mode:
authortmk <nobody@nowhere>2011-03-10 00:50:27 +0900
committertmk <nobody@nowhere>2011-03-10 11:17:54 +0900
commitcec254950509038ca9c805e87feea9091d77d29f (patch)
treec4f542b18dc080e32508aced1ee0ccce5cbf3a53 /adb_usb
parent1a7c3585ed9a68099e371b3180a404dd5d08ce1a (diff)
downloadfirmware-cec254950509038ca9c805e87feea9091d77d29f.tar.gz
firmware-cec254950509038ca9c805e87feea9091d77d29f.tar.bz2
firmware-cec254950509038ca9c805e87feea9091d77d29f.zip
FIX: send last report when idle timeouts. (pjrc)
Diffstat (limited to 'adb_usb')
-rwxr-xr-x[-rw-r--r--]adb_usb/Makefile2
-rw-r--r--adb_usb/config.h4
-rwxr-xr-x[-rw-r--r--]adb_usb/matrix.c2
3 files changed, 4 insertions, 4 deletions
diff --git a/adb_usb/Makefile b/adb_usb/Makefile
index 61e43a72f..92b9ba1a9 100644..100755
--- a/adb_usb/Makefile
+++ b/adb_usb/Makefile
@@ -44,7 +44,7 @@ USB_EXTRA_ENABLE = yes # Enhanced feature for Windows(Audio control and System c
#---------------- Programming Options --------------------------
-PROGRAM_CMD = teensy_loader_cli.exe -mmcu=$(MCU) -w -v $(TARGET).hex
+PROGRAM_CMD = teensy_loader_cli -mmcu=$(MCU) -w -v $(TARGET).hex
diff --git a/adb_usb/config.h b/adb_usb/config.h
index ea78dd9bd..adc76bd52 100644
--- a/adb_usb/config.h
+++ b/adb_usb/config.h
@@ -17,8 +17,8 @@
/* key combination for command */
#define IS_COMMAND() ( \
- keyboard_report->mods == (BIT_LSHIFT | BIT_RSHIFT) || \
- keyboard_report->mods == (BIT_LCTRL | BIT_RSHIFT) \
+ keyboard_report->mods == (BIT_LSHIFT | BIT_LCTRL | BIT_LALT | BIT_LGUI) || \
+ keyboard_report->mods == (BIT_LSHIFT | BIT_RSHIFT) \
)
diff --git a/adb_usb/matrix.c b/adb_usb/matrix.c
index 72515dce2..db202896f 100644..100755
--- a/adb_usb/matrix.c
+++ b/adb_usb/matrix.c
@@ -87,7 +87,7 @@ uint8_t matrix_scan(void)
_register_key(key1);
}
- if (debug_matrix && matrix_is_modified()) {
+ if (debug_enable) {
print("adb_host_kbd_recv: "); phex16(codes); print("\n");
}
return 1;