aboutsummaryrefslogtreecommitdiffstats
path: root/build_keyboard.mk
diff options
context:
space:
mode:
authorErez Zukerman <bulk@ezuk.org>2016-11-29 08:16:04 -0500
committerGitHub <noreply@github.com>2016-11-29 08:16:04 -0500
commit51ae6da99edd732ccdec6e102bd757e08950d23b (patch)
tree53e316e1fbe468e0b1f65fd11e161ebc74c6ef70 /build_keyboard.mk
parent7b219a7f6016dfe80c1c3db33bcf859e3e355d8d (diff)
parentf946d830f98da0161753d37da9659caa7469cf4f (diff)
downloadfirmware-51ae6da99edd732ccdec6e102bd757e08950d23b.tar.gz
firmware-51ae6da99edd732ccdec6e102bd757e08950d23b.tar.bz2
firmware-51ae6da99edd732ccdec6e102bd757e08950d23b.zip
Merge pull request #918 from jackhumbert/wu5y7
Adds Ergodox EZ RGB lights (both sides using I2C) and implements API base, Midi SysEx API
Diffstat (limited to 'build_keyboard.mk')
-rw-r--r--build_keyboard.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/build_keyboard.mk b/build_keyboard.mk
index 055ce632a..ce505de12 100644
--- a/build_keyboard.mk
+++ b/build_keyboard.mk
@@ -131,6 +131,14 @@ ifndef CUSTOM_MATRIX
SRC += $(QUANTUM_DIR)/matrix.c
endif
+ifeq ($(strip $(API_SYSEX_ENABLE)), yes)
+ OPT_DEFS += -DAPI_SYSEX_ENABLE
+ SRC += $(QUANTUM_DIR)/api/api_sysex.c
+ OPT_DEFS += -DAPI_ENABLE
+ SRC += $(QUANTUM_DIR)/api.c
+ MIDI_ENABLE=yes
+endif
+
ifeq ($(strip $(MIDI_ENABLE)), yes)
OPT_DEFS += -DMIDI_ENABLE
SRC += $(QUANTUM_DIR)/process_keycode/process_midi.c
@@ -174,6 +182,12 @@ ifeq ($(strip $(TAP_DANCE_ENABLE)), yes)
SRC += $(QUANTUM_DIR)/process_keycode/process_tap_dance.c
endif
+ifeq ($(strip $(PRINTING_ENABLE)), yes)
+ OPT_DEFS += -DPRINTING_ENABLE
+ SRC += $(QUANTUM_DIR)/process_keycode/process_printer.c
+ SRC += $(TMK_DIR)/protocol/serial_uart.c
+endif
+
ifeq ($(strip $(SERIAL_LINK_ENABLE)), yes)
SRC += $(patsubst $(QUANTUM_PATH)/%,%,$(SERIAL_SRC))
OPT_DEFS += $(SERIAL_DEFS)