aboutsummaryrefslogtreecommitdiffstats
path: root/converter/ps2_usb/Makefile
diff options
context:
space:
mode:
authorRobin Haberkorn <robin.haberkorn@googlemail.com>2014-07-27 17:07:26 +0200
committerRobin Haberkorn <robin.haberkorn@googlemail.com>2014-07-27 17:38:31 +0200
commit7dde35d4f7cc3cc1569a31e752ea4043133b1a72 (patch)
tree9c91ff60feb667492d76ecfe086849e6fba18b68 /converter/ps2_usb/Makefile
parent388fe60c67dbc4232a979d3de3b3b161a67871e2 (diff)
downloadfirmware-7dde35d4f7cc3cc1569a31e752ea4043133b1a72.tar.gz
firmware-7dde35d4f7cc3cc1569a31e752ea4043133b1a72.tar.bz2
firmware-7dde35d4f7cc3cc1569a31e752ea4043133b1a72.zip
integrated serial mouse drivers as a feature into the firmware architecture
* can be enabled by defining Makefile macro SERIAL_MOUSE_MICROSOFT_ENABLE or SERIAL_MOUSE_MOUSESYSTEMS_ENABLE. * Serial implementation can be chosen via SERIAL_MOUSE_USE_SOFT and SERIAL_MOUSE_USE_UART macros * UART configuration still has to be done in config.h: I added working clauses for both mouse protocols to ps2_usb's config.h
Diffstat (limited to 'converter/ps2_usb/Makefile')
-rw-r--r--converter/ps2_usb/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/converter/ps2_usb/Makefile b/converter/ps2_usb/Makefile
index 1dd23c157..f20039c6f 100644
--- a/converter/ps2_usb/Makefile
+++ b/converter/ps2_usb/Makefile
@@ -91,6 +91,19 @@ PS2_USE_USART = yes # uses hardware USART engine for PS/2 signal receive(recomen
#PS2_USE_INT = yes # uses external interrupt for falling edge of PS/2 clock pin
#PS2_USE_BUSYWAIT = yes # uses primitive reference code
+# Serial Mouse Options
+# You can choose a mouse protocol and the implementation of
+# the underlying serial connection.
+#
+#SERIAL_MOUSE_MICROSOFT_ENABLE = yes # Enable support for Microsoft-compatible mice
+#SERIAL_MOUSE_MOUSESYSTEMS_ENABLE = yes # Enable support for Mousesystems-compatible mice
+#SERIAL_MOUSE_USE_UART = yes # use hardware UART for serial connection
+#SERIAL_MOUSE_USE_SOFT = yes # use software serial implementation
+
+# Optional serial mouse driver features
+# Support scrolling while holding the middle mouse button
+# (currently only supported for Mousesystems mice):
+#OPT_DEFS += -DSERIAL_MOUSE_CENTER_SCROLL
# Optimize size but this may cause error "relocation truncated to fit"
#EXTRALDFLAGS = -Wl,--relax