aboutsummaryrefslogtreecommitdiffstats
path: root/converter/ps2_usb/Makefile
diff options
context:
space:
mode:
authortmk <nobody@nowhere>2014-08-26 05:02:37 +0900
committertmk <nobody@nowhere>2014-08-26 05:02:37 +0900
commitb316f19871ab39e6a75146d74a3b5cca37165f3c (patch)
tree66d06b895fea2e85da612d06604ab59234dc46b7 /converter/ps2_usb/Makefile
parent10eb70acb4c8a03fc5bda32d9c23fc41266aef7a (diff)
parent03fd4a6ff0fcccf8d7683b7fac3d9e6ae4fb635e (diff)
downloadfirmware-b316f19871ab39e6a75146d74a3b5cca37165f3c.tar.gz
firmware-b316f19871ab39e6a75146d74a3b5cca37165f3c.tar.bz2
firmware-b316f19871ab39e6a75146d74a3b5cca37165f3c.zip
Merge branch 'serial-mouse' of git://github.com/rhaberkorn/tmk_keyboard into rhaberkorn-serial-mouse
Diffstat (limited to 'converter/ps2_usb/Makefile')
-rw-r--r--converter/ps2_usb/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/converter/ps2_usb/Makefile b/converter/ps2_usb/Makefile
index 1dd23c157..f20039c6f 100644
--- a/converter/ps2_usb/Makefile
+++ b/converter/ps2_usb/Makefile
@@ -91,6 +91,19 @@ PS2_USE_USART = yes # uses hardware USART engine for PS/2 signal receive(recomen
#PS2_USE_INT = yes # uses external interrupt for falling edge of PS/2 clock pin
#PS2_USE_BUSYWAIT = yes # uses primitive reference code
+# Serial Mouse Options
+# You can choose a mouse protocol and the implementation of
+# the underlying serial connection.
+#
+#SERIAL_MOUSE_MICROSOFT_ENABLE = yes # Enable support for Microsoft-compatible mice
+#SERIAL_MOUSE_MOUSESYSTEMS_ENABLE = yes # Enable support for Mousesystems-compatible mice
+#SERIAL_MOUSE_USE_UART = yes # use hardware UART for serial connection
+#SERIAL_MOUSE_USE_SOFT = yes # use software serial implementation
+
+# Optional serial mouse driver features
+# Support scrolling while holding the middle mouse button
+# (currently only supported for Mousesystems mice):
+#OPT_DEFS += -DSERIAL_MOUSE_CENTER_SCROLL
# Optimize size but this may cause error "relocation truncated to fit"
#EXTRALDFLAGS = -Wl,--relax