aboutsummaryrefslogtreecommitdiffstats
path: root/doc/keymap_makefile_example.mk
diff options
context:
space:
mode:
authorChristopher Browne <cbbrowne@ca.afilias.info>2016-06-13 16:06:03 -0400
committerChristopher Browne <cbbrowne@ca.afilias.info>2016-06-13 16:06:03 -0400
commitdc9bf78f2b1d7d894576d87ea9bfc86d7bb3deee (patch)
tree44f432118882f9176ef6d901dc3d389d28737254 /doc/keymap_makefile_example.mk
parentd649ab34334ff568448c47a04fcf40f1aa960135 (diff)
parent25d4772754186b8ab6ef86c28049da67a460f123 (diff)
downloadfirmware-dc9bf78f2b1d7d894576d87ea9bfc86d7bb3deee.tar.gz
firmware-dc9bf78f2b1d7d894576d87ea9bfc86d7bb3deee.tar.bz2
firmware-dc9bf78f2b1d7d894576d87ea9bfc86d7bb3deee.zip
Merge branch 'master' of https://github.com/jackhumbert/qmk_firmware
Diffstat (limited to 'doc/keymap_makefile_example.mk')
-rw-r--r--doc/keymap_makefile_example.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/doc/keymap_makefile_example.mk b/doc/keymap_makefile_example.mk
new file mode 100644
index 000000000..5eb73246f
--- /dev/null
+++ b/doc/keymap_makefile_example.mk
@@ -0,0 +1,21 @@
+# Build Options
+# change to "no" to disable the options, or define them in the makefile.mk in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif \ No newline at end of file