aboutsummaryrefslogtreecommitdiffstats
path: root/docs/keymap_makefile_example.mk
diff options
context:
space:
mode:
authorNick Choi <nikchi@users.noreply.github.com>2017-05-30 14:17:48 -0400
committerGitHub <noreply@github.com>2017-05-30 14:17:48 -0400
commit2c9f846608cbf91ce936071372634194745994d0 (patch)
tree7fc260baa3bca7ba748117e07fca8aaa186943dd /docs/keymap_makefile_example.mk
parent5393bc6f4eee3d3cb83997e5b03d8e5a5cea85d8 (diff)
parentcb791cf6cdbcd9fd1291f36f6b1a6840753db97f (diff)
downloadfirmware-2c9f846608cbf91ce936071372634194745994d0.tar.gz
firmware-2c9f846608cbf91ce936071372634194745994d0.tar.bz2
firmware-2c9f846608cbf91ce936071372634194745994d0.zip
Merge pull request #2 from qmk/master
pull in new qmk changes
Diffstat (limited to 'docs/keymap_makefile_example.mk')
-rw-r--r--docs/keymap_makefile_example.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/docs/keymap_makefile_example.mk b/docs/keymap_makefile_example.mk
new file mode 100644
index 000000000..f4671a9d1
--- /dev/null
+++ b/docs/keymap_makefile_example.mk
@@ -0,0 +1,21 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif \ No newline at end of file