aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/40percentclub/ut47/rules.mk
diff options
context:
space:
mode:
authorzvecr <z.zvecr@gmail.com>2018-11-12 20:02:28 +0000
committerDrashna Jaelre <drashna@live.com>2018-11-12 12:02:28 -0800
commitb173c05cc25e9394c6e50081c1af707443950104 (patch)
tree36d750ffd81027e29d2dd8ab68274a4a9c4009cd /keyboards/40percentclub/ut47/rules.mk
parent746005acba3a3522eaa2bf1c8014644e1a60c5df (diff)
downloadfirmware-b173c05cc25e9394c6e50081c1af707443950104.tar.gz
firmware-b173c05cc25e9394c6e50081c1af707443950104.tar.bz2
firmware-b173c05cc25e9394c6e50081c1af707443950104.zip
Tidy 40percentclub boards (#4403)
* Remove unnecessary re-definitions for XXXXXXX and _______ * Update 6lit to use KC_NO in layout macros * Update rules.mk to follow current template * Remove use of deprecated function action_get_macro - unused and contents were from old template * Remove use of deprecated function action_get_macro - all code was commented out * Remove use of deprecated function action_get_macro - convert macro to use process_record_user * Convert keymap to consistent use of _______ * fix use of old style header guards * Swap KC_NO for XXXXXXX macro since the swap to the macro for KC_TRANS * Resolve use of ?= in rules.mk files * Remove duplication of rules.mk and config.h in gherkin mjt keymap * Remove unnecessary #includes * Align layout macros so foobar can use gherkin keymaps * Align 6lit layout macros with foobar * Remove ifndef QUANTUM_DIR from keymaps
Diffstat (limited to 'keyboards/40percentclub/ut47/rules.mk')
-rw-r--r--keyboards/40percentclub/ut47/rules.mk31
1 files changed, 24 insertions, 7 deletions
diff --git a/keyboards/40percentclub/ut47/rules.mk b/keyboards/40percentclub/ut47/rules.mk
index b04659866..7495f5edd 100644
--- a/keyboards/40percentclub/ut47/rules.mk
+++ b/keyboards/40percentclub/ut47/rules.mk
@@ -1,5 +1,4 @@
# MCU name
-#MCU = at90usb1286
MCU = atmega32u4
# Processor frequency.
@@ -38,12 +37,26 @@ F_USB = $(F_CPU)
# Interrupt driven control endpoint task(+60)
OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
-# Bootloader
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# atmega32a bootloadHID
BOOTLOADER = caterina
-# custom matrix setup
-CUSTOM_MATRIX = yes
-SRC += matrix.c protocol/serial_uart.c
+
+# If you don't know the bootloader type, then you can specify the
+# Boot Section Size in *bytes* by uncommenting out the OPT_DEFS line
+# Teensy halfKay 512
+# Teensy++ halfKay 1024
+# Atmel DFU loader 4096
+# LUFA bootloader 4096
+# USBaspLoader 2048
+# OPT_DEFS += -DBOOTLOADER_SIZE=4096
+
# Build Options
# change yes to no to disable
@@ -51,12 +64,12 @@ SRC += matrix.c protocol/serial_uart.c
BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
-CONSOLE_ENABLE = no # Console for debug(+400)
+CONSOLE_ENABLE = no # Console for debug(+400)
COMMAND_ENABLE = yes # Commands for debug and configuration
# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-NKRO_ENABLE = yes # USB Nkey Rollover
+NKRO_ENABLE = yes # USB Nkey Rollover
BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality on B7 by default
MIDI_ENABLE = no # MIDI support (+2400 to 4200, depending on config)
UNICODE_ENABLE = no # Unicode
@@ -64,6 +77,10 @@ BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
AUDIO_ENABLE = no # Audio output on port C6
FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+# custom matrix setup
+CUSTOM_MATRIX = yes
+SRC += matrix.c protocol/serial_uart.c
+
ifeq ($(strip $(LED_ENABLE)), yes)
OPT_DEFS += -DLED_ENABLE
SRC += led.c