aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/40percentclub
diff options
context:
space:
mode:
authorNick Brassel <nick@tzarc.org>2020-02-11 07:52:40 +1100
committerGitHub <noreply@github.com>2020-02-10 12:52:40 -0800
commit9398c11b5190372e11cfe20222a9c872710dd86c (patch)
tree5ab7b7425342b84b545af73ef25f35cefbd12389 /keyboards/40percentclub
parent89c528e443561731eb3cf4ed3d49002545421afe (diff)
downloadfirmware-9398c11b5190372e11cfe20222a9c872710dd86c.tar.gz
firmware-9398c11b5190372e11cfe20222a9c872710dd86c.tar.bz2
firmware-9398c11b5190372e11cfe20222a9c872710dd86c.zip
Remove tzarc's Luddite keymap. (#8139)
Diffstat (limited to 'keyboards/40percentclub')
-rw-r--r--keyboards/40percentclub/luddite/keymaps/tzarc/config.h6
-rw-r--r--keyboards/40percentclub/luddite/keymaps/tzarc/keymap.c30
-rw-r--r--keyboards/40percentclub/luddite/keymaps/tzarc/rules.mk1
3 files changed, 0 insertions, 37 deletions
diff --git a/keyboards/40percentclub/luddite/keymaps/tzarc/config.h b/keyboards/40percentclub/luddite/keymaps/tzarc/config.h
deleted file mode 100644
index f8feb798d..000000000
--- a/keyboards/40percentclub/luddite/keymaps/tzarc/config.h
+++ /dev/null
@@ -1,6 +0,0 @@
-#undef RGBLED_NUM
-#define RGBLED_NUM 16
-
-#define QMK_ESC_OUTPUT F4
-#define QMK_ESC_INPUT D3
-#define QMK_LED B0
diff --git a/keyboards/40percentclub/luddite/keymaps/tzarc/keymap.c b/keyboards/40percentclub/luddite/keymaps/tzarc/keymap.c
deleted file mode 100644
index dfa1c499c..000000000
--- a/keyboards/40percentclub/luddite/keymaps/tzarc/keymap.c
+++ /dev/null
@@ -1,30 +0,0 @@
-#include QMK_KEYBOARD_H
-
-// Each layer gets a name for readability, which is then used in the keymap matrix below.
-// The underscores don't mean anything - you can have a layer called STUFF or any other name.
-// Layer names don't all need to be of the same length, obviously, and you can also skip them
-// entirely and just use numbers.
-#define _BASE 0
-#define _FN1 1
-
-enum custom_keycodes {
- QWERTY = SAFE_RANGE,
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [_BASE] = LAYOUT_60_ansi(
- KC_GESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL, KC_BSPC,
- KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC, KC_BSLS,
- KC_CAPS, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_SCLN, KC_QUOT, KC_ENT,
- KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
- KC_LCTL, KC_LGUI, KC_LALT , KC_SPC, KC_RALT, KC_APP, MO(_FN1), KC_RCTL
- ),
-
- [_FN1] = LAYOUT_60_ansi(
- KC_GESC, KC_F1, KC_F2, KC_F3, KC_F4, KC_F5, KC_F6, KC_F7, KC_F8, KC_F9, KC_F10, KC_F11, KC_F12, _______,
- RGB_TOG, RGB_MOD, KC_UP, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, KC_LEFT, KC_DOWN, KC_RGHT, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- BL_INC, BL_DEC, BL_TOGG, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- KC_GRV, _______, _______, _______, _______, KC_RGUI, _______, _______
- )
-};
diff --git a/keyboards/40percentclub/luddite/keymaps/tzarc/rules.mk b/keyboards/40percentclub/luddite/keymaps/tzarc/rules.mk
deleted file mode 100644
index 0613ea866..000000000
--- a/keyboards/40percentclub/luddite/keymaps/tzarc/rules.mk
+++ /dev/null
@@ -1 +0,0 @@
-BOOTLOADER = qmk-dfu