aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/absinthe/absinthe.c
diff options
context:
space:
mode:
authorCody Bender <50554676+cfbender@users.noreply.github.com>2020-04-18 18:40:13 -0600
committerGitHub <noreply@github.com>2020-04-18 17:40:13 -0700
commit7e1c0bd4c093b6a4ff637dc29faef6cfbcbedefe (patch)
treefde57dff2daa7f1ab93dc0aa22eeece016d068e3 /keyboards/absinthe/absinthe.c
parentd2b8398f75f8239b135bfb3772153e32d794c291 (diff)
downloadfirmware-7e1c0bd4c093b6a4ff637dc29faef6cfbcbedefe.tar.gz
firmware-7e1c0bd4c093b6a4ff637dc29faef6cfbcbedefe.tar.bz2
firmware-7e1c0bd4c093b6a4ff637dc29faef6cfbcbedefe.zip
[Keyboard] Add Absinthe keyboard (#8769)
* Initial absinthe setup * Update Absinthe files * Add absinthe ANSI layout * Update absinthe keymaps * Update Absinthe for rev3 * Flip encoder pins * Fix rules.mk * Update absinthe files * Fix absinthe ansi config * Add RGB * Change rules for absinthe for firmware size * Fix pins for rev4 * Fix pins and GESC * Remove GESC from ANSI layout * Rebase upstream/master * Update formatting and convention from 8769 feedback * Format rules.mk
Diffstat (limited to 'keyboards/absinthe/absinthe.c')
-rw-r--r--keyboards/absinthe/absinthe.c17
1 files changed, 17 insertions, 0 deletions
diff --git a/keyboards/absinthe/absinthe.c b/keyboards/absinthe/absinthe.c
new file mode 100644
index 000000000..502139ed0
--- /dev/null
+++ b/keyboards/absinthe/absinthe.c
@@ -0,0 +1,17 @@
+/* Copyright 2020 cfbender
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include "absinthe.h"