aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/acheron/austin/rules.mk
diff options
context:
space:
mode:
authorJoel Challis <git@zvecr.com>2020-02-18 00:54:15 +0000
committerGitHub <noreply@github.com>2020-02-18 00:54:15 +0000
commita2081171de25099b0e6be6faa08954ceff2a953b (patch)
treeb0115aab108c4f8f7157a5865aac046be4740f96 /keyboards/acheron/austin/rules.mk
parentc66930445f7d5941eb847568288046d51f853786 (diff)
downloadfirmware-a2081171de25099b0e6be6faa08954ceff2a953b.tar.gz
firmware-a2081171de25099b0e6be6faa08954ceff2a953b.tar.bz2
firmware-a2081171de25099b0e6be6faa08954ceff2a953b.zip
[keyboard] Austin (#8176)
* Add austin keyboard * Update to use spi ws2812 driver * remove rgb
Diffstat (limited to 'keyboards/acheron/austin/rules.mk')
-rw-r--r--keyboards/acheron/austin/rules.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/keyboards/acheron/austin/rules.mk b/keyboards/acheron/austin/rules.mk
new file mode 100644
index 000000000..17e589ad7
--- /dev/null
+++ b/keyboards/acheron/austin/rules.mk
@@ -0,0 +1,25 @@
+# MCU name
+MCU = STM32F072
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
+
+# Enter lower-power sleep mode when on the ChibiOS idle thread
+OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE